Unable to find device over ethernet


Noobie here. I am trying to follow the documentation for getting started with balenaOS on a Raspberry Pi 3. I hope to connect to the device over ethernet however when I plug my device in it does not show up on the dashboard or is not picked up by CLI interface. I have connected the device to external monitor and it seems to boot properly (i.e. show balena logo).

balena scan results in “Cannot find devices on the local network”
I have also tried searching for a connected device using nmap which is unsuccessful.
Finally I tried setting a static IP for the balena image which didn’t work.

My host machine is running Ubuntu 18.04.2 LTS.
My device is Raspberry Pi 3B and I am using the production image.

If anyone could point me in the right direction, I would really appreciate it.

Thank you.

Hello @josh, could you try connecting your device to the wifi, to make sure the issue is not on the ethernet cable?
Also try using a development image for this test.

Please let me know how it goes, thanks!