Attention. Something went wrong. If it is a compressed .........

Hey
I get this error. I believe I have got other errors as well but I captured this

after once again formating the usb.
From disk utilities: (original danish below)

Type of device: Physical device
BSD device node: disk2
Connection: USB
Device Structure Path: IODeviceTree: / PCI0 @ 0 / XHC1 @ 14
Not read-only: No.
Skelner ml. uppercase and lowercase letters: No.
Unit capacity: 15,518,924,800
Free space (can be deleted + not used): 0
Erasable space: 0
Free space: 0
Space used: 15,518,924,800
Owners turned on: No.
Is encrypted: No.
Can be checked: No.
Can be repaired: No.
Can start: No.
Journal prepared: No.
Disk number: 2
Media Name: SMI USB DISK Media
Media Type: General
Can be pushed out: Yes
Quick memory: No.
S.M.A.R.T. Status: Not supported

Type på enhed : Fysisk enhed
BSD-enhedsknude : disk2
Forbindelse : USB
Sti til enhedsstruktur : IODeviceTree:/PCI0@0/XHC1@14
Ikke skrivebeskyttet : Nej
Skelner ml. store og små bogstaver : Nej
Enheds kapacitet : 15.518.924.800
Ledig plads (kan slettes + ikke brugt) : 0
Plads, der kan slettes : 0
Ledig plads : 0
Brugt plads : 15.518.924.800
Ejere slået til : Nej
Er krypteret : Nej
Kan kontrolleres : Nej
Kan repareres : Nej
Kan starte : Nej
Journal udfærdiget : Nej
Disknummer : 2
Medienavn : SMI USB DISK Media
Medietype : Generel
Kan skubbes ud : Ja
Fast hukommelse : Nej
S.M.A.R.T.-status : Ikke understøttet

Can you tell me whats wrong? Or if you need my info, let me know!

Bless

Perhaps this information is useful:

I used this guide https://ubuntu.com/tutorials/create-a-usb-stick-on-macos#1-overview

I run MacOs Catalina 10.15.7
But I didn’t update before yesterday (or the Mac initiated it and I didn’t stop it)

And another curious thing is that I actually managed to make the live USB at some point. After several attempts. But since there was other bugs when I used Ubuntu, I thought making a new one might help. And yeah, that’s where I am right now.

Thanks!

Hello! What was the OS that you initially run this on? Also did you update your OS now? So we can’t reproduce exactly what happened at the time you started this post?

I believe I was running OS 10.15.4 before. And yeah, the laptop started to update, or at least I didn’t do it intentionally.

Well, I have of course tried again and again. The same error occurs still.

Do you need more information? :slight_smile:

And what I find to be strange is the fact that I actually have managed to create a bootable live USB twice. However there was still many problems with Ubuntu which is why I attempted to create a new live USB pen. In both cases where I succeeded balena came with a trouble msg at first and then afterwards when I tried again it worked. Odd…

Just formatted the USB drive to MS-DOS FAT, GUID partition and then running balena after. Looks like the same problem:

Hello @doktor60,

What version of MacOS are you running now that the update is finished? I can see in the logs you shared that etcher is reporting ‘EBUSY: resource busy or locked’, this usually happens when the OS is using the device and hasn’t released it yet. Until the device is released by the OS, etcher won’t be able to access it.
You should verify that there’s no other application using the device before trying to flash it. Another thing you could check is that none of those OS dialogues where it says that the device couldn’t be mounted are open. If any of those are open, try clicking on ‘ignore’ before flashing the device.

Finally, we’ve seen a few cases were the OS doesn’t grant etcher the right permissions to run. There are two workarounds to fix this as explained here:

  • Go to the “Privacy & Security” panel in MacOS and make sure to add etcher to the “Full Disk Access” (under the privacy tab) list.
  • Try running etcher as sudo as below:
sudo su -
cd /Applications/balenaEtcher.app/Contents/MacOS/
./balenaEtcher

Cheers,
Nico.

Tried your recommendation above…

Living-Room:~ root# cd /Applications/balenaEtcher.app/Contents/MacOS/
Living-Room:MacOS root# ./balenaEtcher
(node:86663) Electron: Loading non-context-aware native module in renderer: ‘/Applications/balenaEtcher.app/Contents/Resources/app/generated/modules/xxhash/build/Release/hash.node’. This is deprecated, see https://github.com/electron/electron/issues/18397.
(node:86663) Electron: Loading non-context-aware native module in renderer: ‘/Applications/balenaEtcher.app/Contents/Resources/app/generated/modules/@balena.io/usb/build/Release/usb_bindings.node’. This is deprecated, see https://github.com/electron/electron/issues/18397.
ready-to-show: 2901.933ms
Checking for update
Generated new staging user ID: 4e19d546-076d-56d8-89d7-e023a628dab3
Error: Error: net::ERR_CERT_INVALID
at SimpleURLLoaderWrapper. (electron/js2c/browser_init.js:93:6395)
at SimpleURLLoaderWrapper.emit (events.js:223:5)
{“stack”:“Error: net::ERR_CERT_INVALID\n at SimpleURLLoaderWrapper. (electron/js2c/browser_init.js:93:6395)\n at SimpleURLLoaderWrapper.emit (events.js:223:5)”,“message”:“net::ERR_CERT_INVALID”}
{“stack”:“Error: net::ERR_CERT_INVALID\n at SimpleURLLoaderWrapper. (electron/js2c/browser_init.js:93:6395)\n at SimpleURLLoaderWrapper.emit (events.js:223:5)”,“message”:“net::ERR_CERT_INVALID”}
2020-12-03 15:02:41.681 balenaEtcher[86659:8888116] NSNotificationCenter connection invalid
2020-12-03 15:02:41.683 balenaEtcher[86659:8888116] Connection to notification center invalid. ServerConnectionFailure: 1 invalidated: 0
2020-12-03 15:03:08.073 balenaEtcher[86659:8888948] NSNotificationCenter connection invalid

Hi Christine

Did the things Nicolas mentioned in the message above work for you?

No, posted the Terminal output above.

@anujdeshpande
UPDATE - Limited to 3 replies as I’m a new user… so additional info below.

No, its a 2016 MBPro. balena has worked fine for me before on this computer. This is the first time I’ve used it though since upgrading to Big Sur.

I had this issue yesterday and it took me hours to flash Volumio. Then it was down to something on the SD card that balena didn’t like. Reformatted the card and it worked fine. Reformatted the card several times today and no go. Card is Sandisk Ultra 32Gb.

@anujdeshpande
Further update - I got balena to flash Volumio by using the URL http://updates.volumio.org/pi/volumio/2.853/volumio-2.853-2020-11-20-pi.img.zip
This worked fine, but not from the downloaded image.

Is this a Mac with the new M1 chip

1 Like

Thanks for your reply Nico!

So I am now running Cataline 10.15.7

Is there a way for me to make sure OS has released the device? As in, how do I verify it as you suggest?
I have just looked and can’t figure out what it should be.
Regarding the OS dialogues there are none. Should there be one saying it can’t be mounted?

I have already given etcher full access actually (I thought that was the key too)

So when I run the app now and try to flash I get this message (three times in a row):
Skærmbillede 2020-12-03 kl. 09.49.13

And I also tried with the sudo command - same results. Here is the log:
muffs-mac:MacOS root# ./balenaEtcher

(node:19203) Electron: Loading non-context-aware native module in renderer: ‘/Applications/balenaEtcher.app/Contents/Resources/app/generated/modules/xxhash/build/Release/hash.node’. This is deprecated, see https://github.com/electron/electron/issues/18397.

(node:19203) Electron: Loading non-context-aware native module in renderer: ‘/Applications/balenaEtcher.app/Contents/Resources/app/generated/modules/@balena.io/usb/build/Release/usb_bindings.node’. This is deprecated, see https://github.com/electron/electron/issues/18397.

ready-to-show: 657.867ms

2020-12-03 09:53:11.946 balenaEtcher[19198:1854951] NSNotificationCenter connection invalid

2020-12-03 09:53:11.948 balenaEtcher[19198:1854951] Connection to notification center invalid. ServerConnectionFailure: 1 invalidated: 0

(the rest in the next post due to restrictions on me being a new user)

Any ideas?

And once again, thank you for the effort! Highly appreciated :slight_smile:

The rest, part 1, of the log:

{“message”:“getaddrinfo ENOTFOUND balena.io”,“stack”:“Error: getaddrinfo ENOTFOUND balena.io\n at GetAddrInfoReqWrap.onlookup [as oncomplete] (dns.js:60:26)”,“config”:{“url”:“https://balena.io/etcher/static/config.json",“method”:“get”,“headers”:{“Accept”:"application/json, text/plain, /”,“User-Agent”:“axios/1.5.111”},“transformRequest”:[null],“transformResponse”:[null],“timeout”:0,“responseType”:“json”,“xsrfCookieName”:“XSRF-TOKEN”,“xsrfHeaderName”:“X-XSRF-TOKEN”,“maxContentLength”:-1},“code”:“ENOTFOUND”}

The very last part: (sorry for the messy way of doing it but that’s the way I can go around the restrictions)

{“message”:“getaddrinfo ENOTFOUND balena.io”,“stack”:“Error: getaddrinfo ENOTFOUND balena.io\n at GetAddrInfoReqWrap.onlookup [as oncomplete] (dns.js:60:26)”,“config”:{“url”:“https://balena.io/etcher/static/config.json",“method”:“get”,“headers”:{“Accept”:"application/json, text/plain, /”,“User-Agent”:“axios/1.5.111”},“transformRequest”:[null],“transformResponse”:[null],“timeout”:0,“responseType”:“json”,“xsrfCookieName”:“XSRF-TOKEN”,“xsrfHeaderName”:“X-XSRF-TOKEN”,“maxContentLength”:-1},“code”:“ENOTFOUND”}

2020-12-03 09:53:16.406 balenaEtcher[19198:1855607] NSNotificationCenter connection invalid

2020-12-03 09:53:21.071 balenaEtcher[19198:1855607] NSNotificationCenter connection invalid

Hey anujdeshpande

The macbook pro retina I am using is early 2013, 15 inch.
I guess it doesn’t have the new chip right

And thanks!

Hi Christine

If the URL worked, but your downloaded image didn’t - maybe the image wasn’t downloaded correctly. Do you have the MD5 checksum for the image? This will let us figure if the image that you have downloaded is complete and not missing anything.

Hey doktor60

Yeah your laptop definitely doesn’t have the new chip. About checking for mounted devices under MacOS, you can check the Disk Utility application. It will show you all mounted devices including the one that has your operating system installed.
If you want to verify if the device has been removed, you can look at the status of that device in this application.

Hmm. Actually I have downloaded the image (ISO) twice. And have tried several times with both.
I am not sure what the MD5 checksum is?

1 Like

So after reading your msg I opened Disk utlity, which I have used so many times, and unmounted the device manually. Then I tried again one time with no luck, but second time worked and now I should have a live USB. Going to test if it works correctly because I have had some problems with it being unstable and not able to catch WiFi!

Thanks though! I must admit I didn’t think of unmounting manually. Perhaps it’s obvious but wasn’t mentioned in the otherwise detailed guide.

But still odd I would say, that it never works at first. I would assume that’s not normal or?

hey doktor60 -

Unfortunately we are having two topics in this one forum thread :slight_smile:
The MD5 instruction was for the other user. It has nothing to do with your issue I believe.

About the live USB - let us know if that works. That can help us debug. Ideally you shouldnt have to manually unmount it from Disk Utility - as your rightly figured out. If for some reason you have to do that for a particular image on a particular OS, its most likely a bug that needs some attention
Let us know if the live disk works as expected

Ahh okay. No problem.

Well, I could boot up but still Ubuntu seems not to be able to detect the wifi-adapter. Oddly (again again) I was able to do it once I believe. That may be out of the scope of this forum though or?

So should the USB pen unmount itself upon being formatted or?

Now, I have actually downloaded another ISO. The newest, before I had the LTS.
And I unmounted manually again, and etcher appears to work smoothly now. Starting to flash in first try!