Asus Tinker Board S R2.0

Asus Tinker Board S R2.0 Wifi issue. When using the image for the Tinker Board S, and then running nmcli dev (while connected per ethernet), i am unable to find my wifi interface, therefore my question if the R2.0 isn’t supported? Or if there might be some other issue here? Everything apart from Wifi seems to work (code update, SSH, logs, and so on). Please note: I’m running a development image.

Hi there, if nmcli dev wifi shows nothing, then maybe check ifconfig to see if you have a wlan interface running at all? Maybe also check dmesg to see if there are any messages about the wifi interface in there, maybe it will give us some clues as to why it isn’t working. What version of balena OS are you using?

Thanks for your response. Unfortunately ifconfig doesn’t show any wlan interface at all (and i know its working as with the default tinkerboard debian OS it worked).

When running dmesg | grep wlan i got the following output:

root@135ad7e:~# dmesg | grep wlan
[    3.718753] usbcore: registered new interface driver rndis_wlan
[    7.744727] [WLAN_RFKILL]: Enter rfkill_wlan_init
[    7.751738] [WLAN_RFKILL]: Enter rfkill_wlan_probe
[    7.758679] [WLAN_RFKILL]: wlan_platdata_parse_dt: wifi_chip_type = ap6212
[    7.767928] [WLAN_RFKILL]: wlan_platdata_parse_dt: enable wifi power control.
[    7.777452] [WLAN_RFKILL]: wlan_platdata_parse_dt: wifi power controled by gpio.
[    7.787259] of_get_named_gpiod_flags: can't parse 'WIFI,poweren_gpio' property of node '/wireless-wlan[0]'
[    7.787264] of_get_named_gpiod_flags: can't parse 'WIFI,vbat_gpio' property of node '/wireless-wlan[0]'
[    7.787268] of_get_named_gpiod_flags: can't parse 'WIFI,reset_gpio' property of node '/wireless-wlan[0]'
[    7.787293] of_get_named_gpiod_flags: parsed 'WIFI,host_wake_irq' property of node '/wireless-wlan[0]' - status (0)
[    7.787297] [WLAN_RFKILL]: wlan_platdata_parse_dt: get property: WIFI,host_wake_irq = 150, flags = 0.
[    7.799133] [WLAN_RFKILL]: rfkill_wlan_probe: init gpio
[    7.806525] [WLAN_RFKILL]: Exit rfkill_wlan_probe

I’ve tried using the newest OS 2.38.3 and the previous one 2.32, both with the same outcome.

Hi @lukasknk,

I’m not certain we have the actual R2.0 board in our offices, so unsure if we’ve tested with its connectivity chipsets specifically. This device-type was originally created for the older TinkerBoard S, so if there are differences, it’s possible we’re not accounting for them.

We’ve reached out to the team that manages our hardware testing to confirm and will get back to you once we know for sure.

Awesome, thanks for that. I believe that would be a huge benefit as due to the current situation regarding raspberry pis i think more people are going to switch to tinker boards, at least until the Pis are available again.

Hey Kenna

Could you already get any information from the team? Having no WIFI can be quite a problem in certain environments so i really hope we can find a solution here.

Appreciate your help.


It looks like our priority for adding support for the Tinkerboard S R2.0 is quite low since we have no other demand for it at the moment. Can you share a bit more about your use-case and volumes so that I can help re-prioritize if needed?

Else, are there any other supported boards (for instance the RockPi 4B) that you could test as an alternative? If so, our full list of currently supported devices is here: Single-board computers - Balena Documentation

If you happen to be in contact with ASUS, we would welcome them to add support themselves as well, which other hardware manufacturers have done with us in the past.

Hey @the-real-kenna,

We are planning to roll-out 50-200 Devices this year. Originally we planned to use RPis for that. But due to the massiv shortage of these devices we are unable to do so. Therefore we started analysing alternatives. Due to their similarities and there availability we decided to go with Tinkerboards. But in a lot of environments having no WIFI can be a killer. As we already have a considerable stock of Tinker Boards we can’t simply switch to another board so easily. Our use-case is that we need those devices in a retail environment to track customers movement and report that back to a server in order to do data analyses with that data.

Do you know of a work-around that we can do ourselves to get this to work? I’m sure we are not the only ones with issues like that as more and more people will switch to Tinker Boards due to the Pis shortage.

I’m thankful for your help on this.


I’m so sorry for the delay in my reply! There are two options you could consider:

  1. You could build the image yourself, assuming someone on your team has experience with Yocto: balenaOS - Docs

  2. If not, we offer a service where we can onboard and maintain updates to the device on your behalf; you can see the pricing listed here: balena - Scale pricing from prototype to enterprise usage I would suspect it would be Tier 1 since the similarities between the one we support and this overlap quite a bit

If you’d like to go the second path, you can reach out to us via the contact form (balena - Contact sales) and the Customer Success team will get you started working through the process, which includes sending 2 of the devices to our hardware team for integration.