WiFi / wlan0 not available at all

Whatever I tried, can’t get WiFi working.

So I installed balenaOS 2.47.0 on RPi2 (with WiFi-Dongle) and on RPi3 but can only get them online via LAN. Rebooting them or disconnecting from ethernet will let the ACT LED show connection error.

When connected via LAN and starting a Host OS terminal in balenaCloud I tried various checks.

ifconfig not returning any wlan
nmcli d wifi list returns nothing (not even headings)
nmcli device status also doesn’t show any wlan

Tried also to run those commands with my RPi3 and the WiFi Dongle installed to check if maybe the onboard wifi is broken but returns same results. The RPi3 running raspbian connects to wifi without any hassle.

Hi there, this feels like the OS not seeing the USB hardware at all. What does lsusb -t show?

root@35584d7:~# lsusb -t
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=dwc_otg/1p, 480M
    |__ Port 1: Dev 2, If 0, Class=, Driver=hub/5p, 480M
        |__ Port 1: Dev 3, If 0, Class=, Driver=smsc95xx, 480M
        |__ Port 2: Dev 4, If 0, Class=, Driver=, 480M

But since I’m using a RPi3 I shouldn’t need the WiFi Dongle because there is a built in WiFi.

Hello, can you check dmesg on the host for errors related to nm and/or wlan interfaces? Feel free to post the logs in here if not sure what to search for.
nmcli device status not showing the interface is what is troubling to me.

output.log (20.8 KB)

Can’t find any logs about wlan or nm at all.

Hi, thanks for providing those logs, which don’t indicate any issues. Can you paste the output of nmcli device status - I appreciate you previously said wlan isn’t showing but it’d help to see the output. Also, just ruling out you haven’t disabled the wifi e.g. via the dtoverlay in config.txt or via a configuration variable in balenaCloud?

root@35584d7:~# nmcli device status
DEVICE           TYPE      STATE      CONNECTION         
eth0             ethernet  connected  Wired connection 1 
supervisor0      bridge    connected  supervisor0        
balena0          bridge    unmanaged  --                 
br-2bc61d89346f  bridge    unmanaged  --                 
resin-dns        bridge    unmanaged  --                 
veth14a41d6      ethernet  unmanaged  --                 
lo               loopback  unmanaged  --                 
resin-vpn        tun       unmanaged  -- 

Didn’t even know that I can disable wifi, so no for that question.

That is strange and I guess we can rule out a hardware issue if working with Raspbian. Can you confirm the host OS version you used for the Pi3 as in did you choose the Raspberry Pi 3 device type or Raspberry Pi 3 (using 64bit OS)? Is it a development or production version? Did you download the image for each device from the balenaCloud dashboard?

I chose Raspberry Pi 3 as device type (not 64bit) and it is production version. (Also tried development and 64bit but neither worked.) Furthermore I installed balenaSound if that can may be an issue? For the RPi2 I created a new device in balenaCloud and set it to use the Raspberry Pi 2 as device type when downloading the image.

Atm I’m only running this one RPi3 with latest balenaOS version and connected via ethernet.

Thanks for confirming, can you send the output of the command cat /mnt/boot/config.txt. You can run this from the host OS. Just want to ensure some accidental config variable isn’t the root issue.

Since the output was too long to copy it from the terminal inside balenaCloud I copied it directly from the sd card (/Volumes/resin-boot/config.txt)

config.log (35.4 KB)

Thanks, that rules that out. I’m at a bit of loss what else to suggest other than defective hardware. Perhaps as one final try you could create a new empty application, download the image and reflash the device and do not push anything to it and see the output of nmcli device status when the device is in this fresh state?

So created a new application and flashed it on my sd card. Started the RPi3 at first boot without ethernet connected. After some short time the ACT LED shows again no connection. Pluged the ethernet cable in and let the RPi3 boot again. Now he shows up in balenaCloud. Output of Network Manager:

root@20986c0:~# nmcli device status
DEVICE           TYPE      STATE      CONNECTION         
eth0             ethernet  connected  Wired connection 1 
supervisor0      bridge    connected  supervisor0        
balena0          bridge    unmanaged  --                 
br-ead835d0f90b  bridge    unmanaged  --                 
resin-dns        bridge    unmanaged  --                 
lo               loopback  unmanaged  --                 
resin-vpn        tun       unmanaged  --    

Well I think I’m now running balenaSound via ethernet since it’s the only way I can get it working. Thanks for your support anyway.

Hello I think the dmesg logs you sent us is from the pi2, can you also sent us the dmesg logs from the pi3?

I know this might be asking the obvious, but I don’t see it mentioned anywhere – when downloading the image from the dashboard, did you tell the device to use WiFi and provide the network SSID and passphrase? Without those settings, the interface will not be configured.

Yes sure I did. :smiley: I even checked manually the resin-wifi-01 file if it was correctly configured. I also tested to rename the resin-wifi-01 to resin-wifi because the file is named that way in the documentation / guide.

Hi,

Can you grant support access so we can take a look at one of the devices (with both LAN and WiFi)? We can take a look from our end.

Thanks,
John