Wifi connection on WIFI card

Hi guys,

Recently when we are using UP-Squared (one of the UP-boards) to deploy the standard UP image with WIFI card on board (m.2 2280 pcie), we found that after the installation, Wifi is not detected and can not be used. (Of course the image was set up with Wifi ssid and password)


  1. when we type lsusb, the wifi card is detected, but we go to the /resin-boot/system-connections/ the wifi configuration file does not exist.
  2. the lspci option is not available.
  3. when we type iwconfig, either interface has the wireless extensions.

So right now we are stuck on this, do you guys maybe have any idea how to work out of this?

Any comment is appreciated


Hey @Yiyu, how are you checking /resin-boot? In runtime inside the device? As that place would not have the configuration, at runtime it will be at /etc/NetworkManager/system-connections

So did you download the image you used to flash from our dashboard? Configured the wireless information in that? Or are you using the open source, unmanaged OS image?

The UP board is a flasher image type, if you have the storage media that you flashed the board from, on the flash-boot partition needs to have a /system-connections/ folder, and your connection settings in there.

If the network interface shows up with iwconfig, that’s a good sign, in my opinion likely the configuration wasn’t added. But to be clear, we likely haven’t tested the OS with that particular WIFI card.

A bit of background info, hopefully clearing things up:

  • the original images have the NM configuration on the resin-boot partition in non-flasher, and the flash-boot partition for flasher types
  • at flashing or boot time, the configuration from there is copied over to the device’s state partition, so it can be used even with read-only root file system
  • at runtime, if you connect to the device, the copied settings should be available in /etc/NetworkManager/system-connections
  • in the runtime system, /resin-boot is not used, that’s a helper folder so that a single OS image can bring the information for both the boot and root partitions to the device for OS updates.

The questions above should help us give you more specific advice of what might be going on.

Hi Imrehg, thanks for the reply. Yes, we download from the dashboard with the wireless information filled in

the wifi card we are using is the Intel AC3160 m.2 2230 (with blue tooth and wifi ).

we used lsusb command and the bluetooth is detected (becasue blue tooth is going through the usb) which means the card is detected

but the command lspci is not available in Resin OS so we don’t know if the wifi module is also detected since the wifi module goes through the pci lane

And the iwconfig shows no interface is recognizing the wifi module, so the wifi is not working out of the box.

we checked the /etc/NetworkManager/system-connections, yes the wifi configuration file is there.

So right now I think the problem is that the system does not recognize the wifi module, then we tried another wifi card from another company Bointec, the wifi card is still not recognized.

Could you give us some more information that we somehow use it

thanks a lot!


Hi Yiyu,

Can you please provision a test device with the Intel wifi card attached and provide support access to it so that we can take a look? Also please add a Debian Buster based single-container application to it - an empty one, that we can use for installing additional tools if needed. Then send me a dashboard link in a private message with the support access enabled so that we can check what the issue is.

Please let me know if you have any questions.


Hi Zahari

Appreciate your reply!

Hope you already know that we are currently using the free plan

we don’t know how to add Debian Buster based single-container application to it

Maybe you have any interesting sources that might help?


Hi Yiyu,

No problem about the free plan. We are interested in the compatibility issue you face.

I will get back to you in a few hours with more information on how to include the application.

Thanks a lot,

In order to have a Debian Buster based application container you need to add such a Dockerfile.template in your main application folder:

FROM resin/%%RESIN_MACHINE_NAME%%-debian:buster

COPY run.sh /usr/src/app
WORKDIR /usr/src/app

CMD ./run.sh

Then add in the same folder a run.sh file with the following contents:

sleep infinity

Please let me know if you have any questions.

Hi Zahari

Thanks I would definitely try to install it and let you know asap


Hi Zahari

How can I send you a private message?


I pinged on in a PM now. Other than that you my click on my username and you will see a blue button ‘Message’.

The firmware for the wireless adapter is not found:

[    2.773338] iwlwifi 0000:04:00.0: enabling device (0000 -> 0002)
[    2.779862] iwlwifi 0000:04:00.0: Direct firmware load for iwlwifi-3160-17.ucode failed with error -2
[    2.779890] iwlwifi 0000:04:00.0: no suitable firmware found!

There are other microcode firmware blobs available, but this one looks relatively newer to the included ones. I will ping our devices team for more information on this.

Hi Zahari

thanks for the feedback but it’s strange that one of our clients is good with Resin OS on UP board with the Intel wifi card

Do you have any idea?


My guess is that he is using a different revision on the card, which has the firmware included in the OS.

Hi Zahari

Then I will check with them, but I don’t think they are using the different revision.

Because they want to change the wifi card to another brand, what do you suggest from the respective of Resin?

We already tested with the new Wifi card they want, it has the same problem as the Intel wifi card, so I suppose Resin IO didn’t include this firmware right?

Could you also have a look at the wifi chip card to see what the problem with that wifi chip?


Let’s do the same for the other WiFi card. You may plug it in the device and ping me when the device is online so that I can take a look at why it is not loading. Please also send me the exact model of the WiFi card.

We have to update the firmware for the Intel card in our OS, but let’s wait for a response from our devices team on when this could be possible.

Hi Zahari


yes it is online now with the other wifi card, the exact model of the wifi chip is Bointec DGF109A (it is a 2T 2R wifi card), it is Chinese hardware company manufacturing this wifi card.

Just for your reference, we just checked the firmware of Bointec it uses under Ubuntu is ath10K/QCA6174

Thanks a lot!


I looked the device now. This is a similar issue indeed. The ath10K driver is not included in the OS, but should be present when the kernel is updated.

That firmware should be available since kernel 4.0

Hi @Yiyu
We will add the missing firmware file in our next OS release for the up board.
We are planning to release balenaOS v2.26.0+rev1 soon, which should resolve this issue.
We will give you a note once this happens.

Hi @thgreasi

thanks a lot!