Airplay and Multiroom stopped working - baffled


I’ve got 3 devices I’ve run as a multi-room setup. It’s worked months (maybe years?) in the past, but stopped at some point and I hadn’t been able to return to it. I’d like to get it running again.

These are the 3 devices in the system:

  1. Pi 4B
  2. Pi0W with a PiMoroni PhatDac
  3. Pi0W with some generic HiFiBerry PiHat

The Pi4B is connected with ethernet and is the multi-room server.
The Zeros are connected with WiFi.

I run a mesh network with 2 routers. Signal strength should be pretty strong.

I’ve made sure I have the latest recommended OS and Supervisor Version on each.

I’ve been selective about what services I run as a way of decreasing the load and troubleshooting this issue. So:

  • I’ve disabled spotify on everything because I don’t use it.
  • I’ve disabled bluetooth because I can use airplay, but ideally I would use both.
  • I’ve disabled multi-room server on the PiZeros and multi-room client on the RPi4

I rebooted them all, waited a bit, then sent sound to the RPi4 as a way to test. I’m not getting sound on the PiZeros, but I have complete logs!

On the Zeros I’m seeing a lot of this.

multiroom-client  2023-02-15 00-05-09.310 [Error] (Controller) Error: Connection refused
multiroom-client  2023-02-15 00-05-09.312 [Error] (Connection) Error in socket shutdown: Socket not connected
multiroom-client  2023-02-15 00-05-10.319 [Error] (Connection) Failed to connect to host '', error: Connection refused

I sent a bluetooth signal to one of the PiZeros to test and got sound – it was choppy and skipped, but I did get sound.

Any help would be appreciated!