Multiroom-client keeps exiting

I’m trying to get a multi-room setup working and hitting some snags.

  • I’ve got an RPi4 as the “hub”
  • I’ve got a RPiZero I’m hoping will operate as the client

I’m using airplay to connect to my Hub and expecting to hear sound on the client. But no luck.

multiroom-client keeps exiting. Logs say this:

multiroom-client  Starting multi-room client...
 multiroom-client  Mode: STANDALONE
 multiroom-client  Target snapcast server:
 multiroom-client  Multi-room client disabled. Exiting...
Service exited 'multiroom-client sha...

I can’t get it to keep running. I tried stopping airplay, bluetooth, and spotify to free up some power, if that was it. No luck.

Any thoughts?

Hi @SteveLambert,

The default mode of operation for the RPi Zero is STANDALONE, which will cause the multi-room client to stop, like you are seeing. You need to set the environment variable SOUND_MODE=MULTI_ROOM, or preferably SOUND_MODE=MULTI_ROOM_CLIENT on the RPi Zero and other older/smaller devices like it.

See these pages for more info on SOUND_MODE:


Ok! That worked.

You know I read that documentation and didn’t catch that STANDALONE was default for the Pi Zero. I knew it wouldn’t run MULTI-ROOM SERVER, but I didn’t realize that.

So thanks!

I wanted to keep the bluetooth option and ability to throw sound at just that device (my partner and kid don’t always want to listen to what I’m listening to) so here’s what I ended up doing:


That seems to be working great.

:thinking: Now I’m wondering what else I can safely disable. Sound-supervisor sounds important.


High 5 :raised_hand:

Side Note:

If anyone’s reading this, the link on links to which includes docs/docs and the link doesn’t work. This happens in a few places on that page.

1 Like

Hey @SteveLambert,

Thank you for the report, we will fix the docs asap.