Adjusting Permissions

Hi everyone,

I am trying to connect my hard drive ssd to etcher instead of a usb. When i click the settings button it does not show an option where I can turn off safety features to allow for it to connect to my ssd. What can I do to connect these two?
Thanks