My SSD isn't detected by the program

I just downloaded balenaEtcher on Windows as I want to burn an image on an SSD. When I press select target, only the main C drive is detected. I have an additional SSD connected which also shows up under “Devices and drives”. Why isn’t it detecting it? Is there anything I can do?

A file has been uploaded using Jellyfish: Jellyfish

Does your etcher show targets as the screenshot above? Can you see what shows up in hidden?

Hi, I don’t have access to your Jellyfish link, but I’m guessing you are referring to balenaEtcher having some hidden drives.

The program only detects 1 drive which is my C drive and that is under “hidden”. There are no other drives in there :confused:

Hello @bageren apologizes for this behaviour of etcher. Could you please confirm your version and as well confirm that Windows can access to the SSD?

Hi. The file I’ve downloaded is called 1.5.122, so I’m guessing that is the version. When I look under “This PC” → “Devices and Drives”, both of my connected SSDs show up just fine.

It would be useful if you can share with us the Etcher Logs. To get the Etcher logs could you please press Control+Shift+I to open up the Developer Tools, go to Console, then copy/paste those logs here, so we can have a look at where it is failing. Thank you

Here is the log:

Failed to load resource: net::ERR_FILE_NOT_FOUND
electron/js2c/renderer_init.js:13 (electron) The remote module is deprecated. Use instead.
log @ electron/js2c/renderer_init.js:13
gui.js:90483 _____ _ _
| | | | |
| |
| |
| | ___ _ __
| || / | ’ \ / _ \ '|
| |
| || (
| | | | / |
/ ____|| ||___||

Interested in joining the Etcher team?
Drop us a line at

Version = 1.5.122, Type = nsis
gui.js:58418 Tue Sep 07 2021 19:14:39 GMT+0200 (Central European Summer Time) Application start ({“packageType”:“nsis”,“version”:“1.5.122”,“sample”:0.1,“applicationSessionUuid”:“fe5e7d95-9c3d-4e4f-b70b-70458dceccdd”,“flashingWorkflowUuid”:“b5e9cb5c-1c5c-48e8-bcb4-159f164271ad”})
gui.js:51120 Tue Sep 07 2021 19:14:46 GMT+0200 (Central European Summer Time) Open image selector ({“sample”:0.1,“applicationSessionUuid”:“fe5e7d95-9c3d-4e4f-b70b-70458dceccdd”,“flashingWorkflowUuid”:“b5e9cb5c-1c5c-48e8-bcb4-159f164271ad”})
gui.js:51120 Tue Sep 07 2021 19:14:49 GMT+0200 (Central European Summer Time) Select image ({“image”:{“isCompressed”:true,“name”:“hiveos-0.6-208-stable@210818.img”,“size”:7549747200,“compressedSize”:1076058368,“isSizeEstimated”:false,“hasMBR”:true,“partitions”:[{“offset”:1048576,“size”:20971520,“type”:“EBD0A0A2-B9E5-4433-87C0-68B6B72699C7”,“guid”:“03661D4C-E4F0-460F-9521-B8131E40507B”,“name”:“HIVE”,“index”:1},{“offset”:22020096,“size”:1048576,“type”:“21686148-6449-6E6F-744E-656564454649”,“guid”:“EAE4D79F-FF2A-4E00-A028-E2A605E42E95”,“name”:“BIOS boot partition”,“index”:2},{“offset”:23068672,“size”:41943040,“type”:“C12A7328-F81F-11D2-BA4B-00A0C93EC93B”,“guid”:“F497799C-3108-4810-868E-CADC44FB7503”,“name”:“EFI System”,“index”:3},{“offset”:65011712,“size”:7484718592,“type”:“0FC63DAF-8483-4772-8E79-3D69D8477DE4”,“guid”:“901FB7C5-4726-4763-81E2-694B642F4A9F”,“name”:“HiveOS root filesystem”,“index”:4}],“extension”:“xz”,“path”:“C:\Users\jespe\Downloads\hiveos-0.6-208-stable@210818.img.xz”,“logo”:false,“blockMap”:false},“sample”:0.1,“applicationSessionUuid”:“fe5e7d95-9c3d-4e4f-b70b-70458dceccdd”,“flashingWorkflowUuid”:“b5e9cb5c-1c5c-48e8-bcb4-159f164271ad”})

I also tried to list the drives by doing this:
const driveList = require("./modules/drivelist/build/Release/drivelist.node")
driveList.list((err, drives) => console.log(drives))

That command logs both of my drives. Here’s the properties on the drive I want it to detect:

  1. blockSize: 512
  2. busType: “RAID”
  3. busVersion: “2.0”
  4. description: “Samsung SSD 850 EVO 250GB”
  5. device: “\.\PhysicalDrive1”
  6. devicePath: null
  7. enumerator: “SCSI”
  8. error: null
  9. isCard: false
  10. isReadOnly: false
  11. isRemovable: false
  12. isSCSI: true
  13. isSystem: true
  14. isUAS: false
  15. isUSB: false
  16. isVirtual: false
  17. logicalBlockSize: 512
  18. mountpoints: [0: {path: “D:”}]
  19. partitionTableType: “gpt”
  20. raw: “\.\PhysicalDrive1”
  21. size: 250059350016

Etcher does not support RAID drives as they could have unintended consequences, even flashing intentionally.

I see, what are my options?

That depends largely on what OS you are on, standard flashing tools include diskpart for partitioning on Windows, parted on Linux, and diskutil on a Mac…then you can just copy the data with dd which is supported on all platforms (but you have to download it on Windows).

I think Rufus works well on Windows too, but I’m not sure…I think a lot of people use that to flash Windows bootable disks that Etcher also doesn’t support.

I’m by no means an expert on RAID drives, so I can’t really say for sure how to flash one, but the internals of the etcher would make it dangerous to use, because it writes directly to memory buffers instead of using the standard drivers, so it is not currently supported.

Do you mind me asking your use case?

I found you guys through HiveOS. They recommended Etcher to write their “Hive image” to my drive. Their website also mentions Rufus so I tried that too, but Rufus wasn’t even able to detect my C drive which Etcher is. I’m on Windows.

Ok, I just realized the drive you’re trying to flash to is the system partition. Your entire operating system is on the disk, and the process that is running etcher is controlled by that OS.

So, what exactly are you trying to do? convert the Windows computer you are using to HiveOS?

If so, you should realize, that’s going to erase that entire disk, so you won’t be able to use that computer, except for mining.

But if that’s what you want to do, it looks like the website’s instructions are saying to download the image flasher image, and flash that to a USB thumb drive using Etcher. You download it from here:

Then, you’ll put that flash drive into the computer you want to use to mine, which could be the very same computer you used to flash the image with, and boot from that image. This is a more complicated process, outside of the scope of this support forum, but it looks like they have a forum that can help you if you get stuck: Booting problems - OS setup and Linux - Hive OS Forum

No, my OS is on my C drive and I’ve connected another SSD that I’m trying to write the image to :slight_smile:

But yea I just found an old USB flash drive that just barely had enough space for the image. I’m writing it to that one right now, and then I’ll try to transfer the OS to my SSD afterwards. Thanks for your help. Hopefully this will work.

Ohh ok, I see. Well, the drive that was showing up in the console was the USB drive. Yeah, then you Windows just isn’t recognizing the drive for some reason. USB mass storage devices (flash drives, ssd, SD card readers, etc.) all use the same USB class and operate on the same protocol, so there’s probably something weird going on. It might in Windows’ drivers, might be something with the SSD, could be another process that has it mounted, etc… But neither Etcher, nor any other program will recognize it unless it’s recognized by your OS.

If you’re trying to diagnose problems with the drive, I would first try it on another computer so you can see if it’s the drive or the computer, and that will tell you where to start.

But anyway, sounds like you have your problem solved, let us know if you need anything else.

Sorry, meant to say “the drive that was showing up in the console was the system drive”, aka, your “C” drive.

Thansk for your help :slight_smile: I just tried to write the image to my USB. After it reached 100% on the validation step, it said “Flash failed!”. Here’s the log (sorry it’s long):

Verifying 1 device, 100% at 18.40 MB/s (total 18.40 MB/s) eta in 0s with 0 failed devices
gui.js:51120 Finish: 7549747200
gui.js:51120 Terminating IPC server
gui.js:51120 Flash results {results: {…}, cancelled: false, skip: false}cancelled: falseresults: averageFlashingSpeed: 4217271.730429668bytesWritten: 7549747200devices: {failed: 1, successful: 0}failed: 1successful: 0__proto__: Objecterrors: Array(1)0: Error: Source and destination checksums do not match: 5b77ba70cdb6b592 !== 46c2140ee43e17ab
at Object. (C:\Users\jespe\AppData\Local\Programs\balena-etcher\resources\app\generated\child-writer.js:3792:44)
at Object.emit (events.js:315:20)
at Object. (C:\Users\jespe\AppData\Local\Programs\balena-etcher\resources\app\generated\child-writer.js:3717:24)
at runMicrotasks ()
at processTicksAndRejections (internal/process/task_queues.js:93:5)code: “EVALIDATION"description: “General USB Flash Disk USB Device"device: “\.\PhysicalDrive2"name: “Error"message: “Source and destination checksums do not match: 5b77ba70cdb6b592 !== 46c2140ee43e17ab"stack: “Error: Source and destination checksums do not match: 5b77ba70cdb6b592 !== 46c2140ee43e17ab↵ at Object. (C:\Users\jespe\AppData\Local\Programs\balena-etcher\resources\app\generated\child-writer.js:3792:44)↵ at Object.emit (events.js:315:20)↵ at Object. (C:\Users\jespe\AppData\Local\Programs\balena-etcher\resources\app\generated\child-writer.js:3717:24)↵ at runMicrotasks ()↵ at processTicksAndRejections (internal/process/task_queues.js:93:5)“proto: Objectlength: 1__proto__: Array(0)sourceMetadata: compressedSize: 1076058368isCompressed: trueisSizeEstimated: falsename: “hiveos-0.6-208-stable@210818.img"size: 7549747200__proto__: Object__proto__: Objectskip: false__proto__: Object
gui.js:51120 Wed Sep 08 2021 01:02:43 GMT+0200 (Central European Summer Time) Done ({“image”:{“size”:7549747200,“compressedSize”:1076058368,“hasMBR”:true,“path”:“C:\Users\jespe\Downloads\hiveos-0.6-208-stable@210818.img.xz”,“partitions”:[{“offset”:1048576,“size”:20971520,“type”:“EBD0A0A2-B9E5-4433-87C0-68B6B72699C7”,“guid”:“03661D4C-E4F0-460F-9521-B8131E40507B”,“name”:“HIVE”,“index”:1},{“offset”:22020096,“size”:1048576,“type”:“21686148-6449-6E6F-744E-656564454649”,“guid”:“EAE4D79F-FF2A-4E00-A028-E2A605E42E95”,“name”:“BIOS boot partition”,“index”:2},{“offset”:23068672,“size”:41943040,“type”:“C12A7328-F81F-11D2-BA4B-00A0C93EC93B”,“guid”:“F497799C-3108-4810-868E-CADC44FB7503”,“name”:“EFI System”,“index”:3},{“offset”:65011712,“size”:7484718592,“type”:“0FC63DAF-8483-4772-8E79-3D69D8477DE4”,“guid”:“901FB7C5-4726-4763-81E2-694B642F4A9F”,“name”:“HiveOS root filesystem”,“index”:4}],“isCompressed”:true,“name”:“hiveos-0.6-208-stable@210818.img”,“isSizeEstimated”:false,“extension”:“xz”},“drives”:[{“size”:8022654976,“isVirtual”:false,“enumerator”:“USBSTOR”,“logicalBlockSize”:512,“raw”:”\\.\PhysicalDrive2”,“error”:null,“isReadOnly”:false,“displayName”:“F:\”,“blockSize”:512,“isSCSI”:false,“isRemovable”:true,“device”:”\\.\PhysicalDrive2”,“busVersion”:“2.0”,“isSystem”:false,“busType”:“USB”,“isCard”:false,“isUSB”:true,“devicePath”:null,“mountpoints”:[{“path”:“F:\”}],“description”:“General USB Flash Disk USB Device”,“isUAS”:false,“partitionTableType”:“mbr”}],“driveCount”:1,“uuid”:“4448cd35-776c-4057-8534-9d12190e7ec7”,“status”:“finished”,“flashInstanceUuid”:“4448cd35-776c-4057-8534-9d12190e7ec7”,“errors”:[{“name”:“Error”,“description”:“General USB Flash Disk USB Device”,“code”:“EVALIDATION”,“device”:”\\.\PhysicalDrive2”}],“devices”:{“failed”:1,“successful”:0},“bytesWritten”:7549747200,“sourceMetadata”:{“isCompressed”:true,“name”:“hiveos-0.6-208-stable@210818.img”,“size”:7549747200,“compressedSize”:1076058368,“isSizeEstimated”:false},“sample”:0.1,“applicationSessionUuid”:“afdd924f-b824-4cc0-9da5-3f08a001dd48”,“flashingWorkflowUuid”:“3853795e-9410-42e6-95eb-9950044f3c6d”})
gui.js:51120 Wed Sep 08 2021 01:02:43 GMT+0200 (Central European Summer Time) SafeWebview loaded ({“event”:{“id”:24,“url”:“",“method”:“GET”,“timestamp”:1631055763979.079,“resourceType”:“mainFrame”,“ip”:“”,“fromCache”:false,“statusLine”:"HTTP/1.1 200”,“statusCode”:200,“responseHeaders”:{“age”:[“291571”],“cache-control”:[“public, max-age=0, must-revalidate”],“content-encoding”:[“br”],“content-length”:[“6109”],“content-type”:[“text/html; charset=UTF-8”],“date”:[“Sat, 04 Sep 2021 14:03:12 GMT”],“etag”:[”“347421fee9c01d36cd9a59789c715055-ssl-df””],“link”:["</webpack-runtime-138c6a38d080d53e7705.js>; rel=preload; as=script, </styles-c4fa86dfd4ad05097eee.js>; rel=preload; as=script, </framework-149d8dfa392460762009.js>; rel=preload; as=script, </50c25a04-efe577ee14c9c53bed03.js>; rel=preload; as=script, </73ad3401-e112b47ad7a992b91ac8.js>; rel=preload; as=script, </532a2f07-16f3498dd087ee7288d4.js>; rel=preload; as=script, </app-087bfee4e842aab03f73.js>; rel=preload; as=script, </c943faba-f859f80ceb7f4f7eab31.js>; rel=preload; as=script, </af13d906-36fdbc23fc7dd2f2b2e7.js>; rel=preload; as=script, </ec1189df-4ae9e03f4545d4f1d61b.js>; rel=preload; as=script, </a9a7754c-29508ff4045f1f93a5f6.js>; rel=preload; as=script, </commons-8fcc2f56d20b76e33299.js>; rel=preload; as=script, </edad6859a763f5239c0343c48608d154b87713d6-282649cf8ac0a71046b8.js>; rel=preload; as=script, </component—src-pages-etcher-success-banner-js-6efe4d4fdc9d35955b7f.js>; rel=preload; as=script, </page-data/app-data.json>; rel=preload; as=fetch; crossorigin, </page-data/etcher/success-banner/page-data.json>; rel=preload; as=fetch; crossorigin"],“referrer-policy”:[“strict-origin-when-cross-origin”],“server”:[“Netlify”],“strict-transport-security”:[“max-age=31536000”],“vary”:[“Accept-Encoding”],“x-content-type-options”:[“nosniff”],“x-frame-options”:[“DENY”],“x-nf-request-id”:[“01FF17ZNW44V7YQ2SJD261DNKP”],“x-xss-protection”:[“1; mode=block”]},“referrer”:"",“error”:“net::OK”},“sample”:0.1,“applicationSessionUuid”:“afdd924f-b824-4cc0-9da5-3f08a001dd48”,“flashingWorkflowUuid”:“3853795e-9410-42e6-95eb-9950044f3c6d”})

I think the interesting part is: “Source and destination checksums do not match: 5b77ba70cdb6b592 !== 46c2140ee43e17ab”

Any idea why this could be happening? I’ve tried twice an both times the validation failed. :confused:

You’re welcome!

That means log means that the verification failed.

Unlike dd, etcher actually validates what it flashes. So as it’s flashing, it’s creating a check sum that it will then use to compare after it reads the output that it just wrote.

So, that probably means the USB drive is worn out. That can happen especially with old drives, drives that have been used frequently, and drives without or with a dynamic wear leveling mechanism.

The solution, unfortunately is to get a new USB drive.

We recommend the SanDisk Extreme Pro drives as they are extremely fast and will last a long time. They are more expensive though.

Hey. I went out and bought a brand new 16 GB USB 3.1 Flash Drive today and tried again on both Mac and Windows. Both places I’m still getting the “Flash failed” error message after the validation.

You wrote that I might see the error if the USB drive is worn out/is old/has been used frequently. None of that should be true for this USB, so I’m really confused and honestly quite frustrated. Any ideas?

@bageren since I see you’re on Windows, the validation error could occasionally mean that the OS is getting hold of the resource in-between the switch from writing to validating in order to create additional system folders, which will then make the validation fail (as etcher validates only data written by etcher during the flashing process) - you should still be able to use the media you just flashed in this case