Fails to boot after flashing


Using the following :

  • balenaFin v1.1
  • Raspberry Pi Compute Module 3 Plus Lite (CM3+L)
  • Etcher 1.5.51

Steps :
I brought the BalenaFin developer kit
I used usbboot to get the balena Fin to boot to storage
I then used etcher to flash 2018-06-27-raspbian-stretch-lite.img
I then unpluged and pluged in the barrel and was presented with the rainbow screen
I then unplugged barrel and replugged prg port

I have also tried
dd if=/home/james/etcher/2018-06-27-raspbian-stretch-lite.img of=/dev/sda
this also resulted in the same issue described above

Also first page of logs

Ok it works with 2019-02-26-Raspbian-lite.img
However this could break things on my end because last time I tried a newer version than specified in the following

Greengrass (gg) refused to run, I will install gg on 2019-02-26-Raspbian-lite.img and see if I run into problems



Hey @james

I’m not sure I’ve fully understood the process you’ve been through already. You downloaded raspbian and used the usbboot flash feature of etcher to flash it to the device. This then didn’t boot. Is the what happened?

I have a fin here that I can try and reproduce with, but at the moment I’m not 100% on what isn’t working.

Sorry for the confusion, basically flashing this version
Meant the balenaFin failed to boot for me.

Do you have a serial console connected to the fin that you could view output on? Also, can you inspect packets either on the ethernet or wifi network, depending on which connectivity method you’re going for?

@james I just tried to download and run the same version of raspbian on my fin, and it worked well. I only tested the shell and network via serial, but in general it’s exactly what I would expect.

I would try to redownload the image and reflash, just to ensure that it’s not been corrupted on the download or write step.

Sorry for the late reply, gg runs fine on 2019-02-26-Raspbian-lite.img so I didn’t bother try again with the older image