128G TF Card Flashing - Not Bootable?

Successfully flashed JetPack onto a 128G TF card, but failed to boot… Just wonder if balena etcher can deal with SDXC, like my TF card is of 128G.

Hi @jiapei100 ,
I am not aware of any restrictions in etcher. Make sure though you are using the latest version. Have you made sure that the hardware you are trying to boot supports that SD card format ?

  1. I am using balenaEtcher-1.5.51-x64.AppImage

  2. The board is: Jetson Nano

It looks a lot of users have the same issue:
https://devtalk.nvidia.com/default/topic/1049855/jetson-nano/jetson-nano-sd-card-image-abnormal/ ?

After going through the thread you posted it is not quite clear if the problem is actually related to etcher.
One way to test this would be to flash the SD card using dd instead of etcher. Unfortunately I can not give you a lot of advice on the Jetson Nano itself.
To flash with dd you would invoke one of the following commands in the terminal as root, make sure you choose the right device as this will not be recoverable:
With an uncompressed image
dd if=<path to image> of=<name of sd card device eg.: /dev/sdb> bs=1M conv=fsync oflag=direct status=progress
With a gzipped image:
gzip -d -c <path to image> | dd of=<name of sd card device eg.: /dev/sdb> bs=1M conv=fsync oflag=direct status=progress

Already tried…
If I use a 32G TF card, both dd and etcher are working properly. My ONLY doubt now is:

  • Is it because of the size? SDHC vs. SDXC ?
  • Or is it because of the quality of the TF card…


As my colleague mentioned above, have you tried to flash the same 128 G TF card with dd? Can you please let us know how it goes?

I’ve also asked the Etcher maintainers if we have any known issues related to your doubts and will get back to you later.