Why does BalenaOS reports 745MB of memory instead of 1GB for CM3?


I’m partially confused regarding the memory report by BalenaOS, both on Dashboards and using free command. Our Raspberry Pi CM3 based board has 1GB of memory, but balenaOS reports only 745MB. What am I missing?


Just noticed some devices report it correctly, e.g. with Host OS version balenaOS 2.51.1+rev1 and Supervisor version 11.4.10 (development) reports it correctly and another device with Host OS version balenaOS 2.58.3+rev1 (production) and Supervisor version 11.14.0 reports it wrong (745MB).

Hi @msadeghi, sounds like you experience this issue: https://github.com/balena-io/balena-supervisor/issues/1471

We already fixed this in the supervisor version v12.0.5. So I suggest updating the device supervisor to the latest available version as listed on the Device Actions menu.


I got this replay from Balena support in November:

So the VMSPLIT_3G setting had been introduced previously, to change the user/kernel addressable memory split, in order to allow more containers to be run on 32bit devices. However, one downside of this was that it reduced the total user addressable memory, which impacted 1GB devices, and because of this the setting was rolled back in balena OS v2.58.6. So you are seeing a real increase in usable memory, not simply a calculation or reporting change.

Balena OS 2.60.1 was available for a short time but was removed. I guess we just have to wait for the next Balena OS release.

Hey @stefang, recently we made it possible for balena users to self-serve update the device supervisor version via the dashboard. Now you can go to Actions menu of the device to update the supervisor to latest version available.

In this case, I suspect there is no need to wait for a new balenaOS release as this issue fixed on the supervisor version already. That’s why I suggest updating the supervisor. If the problem is still there after the update, let’s take a further look.



A supervisor update does not fix the missing memory. I think a Balena OS update is required.

Hello Stefang,
What supervisor version did your device update too? We can debug the issue better for you that way.



I think the issue is solved we are just waiting for a new Balena OS release.

I have two Rpi 3:
Balena OS 2.58.3+rev1, Supervisor 12.3.0, reporting 745 MB total memory
Balena OS 2.60.1+rev1, Supervisor 12.3.0, reporting 973 MB total memory

My under standing from the reply from Balena support is that the total memory is fixed in Balena 2.58.6. As Balena OS 2.58.3+rev1 is the most recent available version it is currently not possible to update to a version were the total memory issue is fixed. Balena OS 2.60.1+rev1 was removed after being available for only a couple of days.

I’m afraid it did not help. I upgraded the supervisor to 12.3.0 and rebootet. Nothing changed. Moreover, I tried to upgrade the OS, however I’m not given an option for upgrading the OS from 2.58.3+rev1 (production) to anything else.


I believe the difference you are seeing in free memory between those versions is due to the fact that VMSPLIT_3G was recently disabled (as it was leaving too little memory on 1GB devices).

So it should juts be a case of waiting for the latest OS version to become available for the Rpi3, which should happen shortly.


Thanks for your quick reply. I’ll wait for the upgrade and update this thread accordingly hopefully soon.

I am also hitting this issue. We are using the Raspberry Pi 3+ Lite module with the BalenaFin 1.1

Hey @msadeghi, there is a new release 2.67.3+rev3 for all the Raspberry Pi variants on the production dashboard now that should have the fixes you are looking for. Can you give it a try and let us know how it goes?

Sorry, I misread the release notes! Release 2.67.3+rev3 is in staging for Raspberry Pi 3 (32-bit) and should be released to production once we’ve completed testing.

I just updated BalenaOS on a Raspberry Pi 3 B+. Here is the result.

BalenaOS 2.60.1+rev1, Supervisor 12.3.0, reporting 973 MB total memory
BalenaOS 2.67.3+rev4, Supervisor 12.3.0, reporting 745 MB total memory

The reduced memory issues was fixed at one point, but in the latest release the problem is back.



I am seeing something similar. Running the BalenaOS 32-bit Raspberry Pi 3B+ base image on a Compute Module 3:

BalenaOS 2.58.3+rev1, Supervisor 12.3.0, reporting 745 MB total memory
BalenaOS 2.60.1+rev1, Supervisor 12.3.0, reporting 805 MB total memory
BalenaOS 2.67.3+rev4, Supervisor 12.3.0, reporting 745 MB total memory

So even for version 2.60.1 it’s not in the range of 1GB. Maybe it behaves differently for the CM3.



Hi @stefang and @bartvanarnhem, thank you for reporting this issue. We confirm that we see the issue on our side as well.

Our devices team is investigating this issue further and we’ll post an update as we make progress.


Hi, the fix has been merged into v2.67.3+rev5: balena-raspberrypi/CHANGELOG.md at master · balena-os/balena-raspberrypi · GitHub so the next version available in balenaCloud will have it.