Why balena not working on windows 8.1

Why does balenaEtcher-potable 1.7.9 isn’t working on my device system,
i’m using windows 8.1 and i downloaded this device thereafter i wanted
to install it on my system but it not working showing “this app can’t run on your pc”
and i beginning to wandered what might have been the cause of this issue interferce
and interfering. Please i need a help from this community.
And im sorry if this is not the right place to write/have this conversation. Thanks!

Hello, you are in the correct place! The error message you are seeing sounds like the one when you try to install the 64 bit version on a 32 bit system. Please double check that the file you downloaded is named balenaEtcher-Portable-1.7.9.exe from the download section of balenaEtcher - Flash OS images to SD cards & USB drives which is the most recent version of Etcher compatible with Windows 8. The download link can be a bit sensitive and can sometimes download an unintended version. If you did get an error executing that file, please let us know so we can troubleshoot further.

Hey Everyone, Balena, a platform for managing and deploying IoT devices, may not work on Windows 8.1 due to compatibility issues. Windows 8.1 is an older operating system and some software applications may not be designed to work with it. It’s possible that Balena may require a newer version of Windows, such as Windows 10, to function properly. If you are experiencing issues with Balena on Windows 8.1, you may want to consider upgrading to a newer version of Windows or contacting Balena support for assistance.


Hi @liti,

Could you check whether your Windows 8.1 machine is running a 32bit or 64bit OS? This may be found by following this Microsoft guide: 32-bit and 64-bit Windows: Frequently asked questions - Microsoft Support

If you are running a 32 bit OS, you will need to download the Legacy 32bit Portable version from the Etcher download page. Please let us know if that still doesn’t work after you’ve done so, or if any questions.


I downloaded BalenaEtcher-potable-1.7.9 on Windows 8.1 and it worked properly
though i encountered trial the first time i downloaded it on the system because it didn’t and refused to work at first,
thereafter i downloaded it again and it worked.

I have a similar problem. I wonder whether you can offer some advice.

I’m running 64-bit, Windows 8.1 pro.

I’ve been trying to download Balena Etcher … but nothing appears in my Downloads Folder.

Your downloads page says that I should use ‘v7.9.0.’ … but I don’t know where to find this.

Fingers crossed!