Variable environment not work

In this moment, I have a problem with all my ENVIRONMENT variables. Until yesterday this work OK, but in this moment any Environment Variables don’t work. I have three nodes offline for this reason

What change in How Can I fix this error?

Hi @leandro, we are currently deploying a major update to the backend, which may explain the issues you are seeing. Our team is investigating a similar issue reported by other users. Would you be able to share any more information you have, such as the OS version your devices are running? That would help us investigate further.

Resin OS 1.6.0. I have a serious problem with my current client… the node is down

Okay, yes, this issue seems to be affecting 1.x devices. We’re actively working on a fix and will keep you updated.

I need know the time of the this fix… because other option is replace the OS Version in the old nodes… My client is call me each 10 minutes

Hi Leandro, we’re still investigating.

We have a fix for this identified and will be pushing it out to production shortly. I’ll update you when it is available.

@leandro this should be fixed now. Let us know if you continue to have any issues.

Thanks. Anyway I updated the old nodes to the new version Resin OS.

In this moment I have the same problems with the nodes… It doesn’t work Environment Variables… But this occasion affects the nodes Resin OS 2.2.0+rev1 (prod). I’m very worry because in a Restart a Node already doesn’t work for this reason… help me!

My code reports: Not Defined XXXX Property in Environment Variables

I don’t understand… The reason is that this node now in the moment to add a Environment Variable appers two: main and service1. All variables pre-defined in main already doesn’t work… Now I defined all the variables in service1 and works now. What is the reason? because in the morning the node works fine

Hi @leandro,

There are indeed two places to set variables. The Fleet Configuration section is for managing aspects of resin’s behavior (so things like whether to use delta updates, certain hardware configuration options, etc.). The Service Variables are passed into your application container and can be used for whatever purpose needed by your application.

The reason things are working now is that we identified a bug that affected some resinOS versions shortly after we updated the backend and have now resolved that issue. So things should be working properly now.

OK… but which is the cause of two option in the Environment Variables? In my case are main or service1… Because service1? I haven’t configure anything

Other problem… The node restart doesn’t work fine :frowning:

Sorry, I misunderstood your question. We’ve changed back to “main” for now for your default service so if you do a push again, that should be resolved.

For the restart, do you mean the container restart button in the dashboard? Is it having no effect at all?

Hi there I am currently experiencing major issues when changing/initializing environmental variables.

My container (main service) goes into a boot loop exciting, killing, installing and starting the same service. The problem appeared around 4 hours ago.

Device: Raspberry Pi 3
Resin OS: 2.12.0+rev1 (dev)
Supervisor version: 7.1.7

could you share the dashboard link for the device and grant us support access from the device’s actions page?

I have enabled support access.

Thanks for the help

I found the error. The result I was getting was due to changing 2 environmental variables together. I solved my issue by changing one at a time.

As much for the benefit of posterity and the audience:
2.12.0 had a bug with certain hostnames, that later OS versions have resolved.