Using display output on a BeagleBone Black

Hey guys, I’m going to get right to the point. I am stumped.

I have a project that already works under a vanilla Debian system. I wanted to transfer this to Balena. The project is this; there is a backend that does what backends do and then I’ve got a frontend that displays the process or result or whatever it is through a web browser like midori or firefox. And the web browser is made visible by using a display connected to the BeagleBone Black directly. I guess it’s kind of like a kiosk without any input.

All solutions that all a gui or browser to be displayed are either not applicable because I can’t add any dependencies to the HostOS, or the BeagleBone Black is not supported.

Put simply, I am having trouble finding a solution that will display a browser to the screen hooked up to my device because…well, Docker containers. Can anyone point me in the right direction?

@aslansutu Firstly, welcome to the forums! Great to have you here.

I wonder if one of our existing projects or blocks might help with this, I’d suggest you check out balenaDash and/or the Browser Block which. Links to both below:

balenaDash tutorial - Make a web frame with Raspberry Pi in 30 minutes
Browser Block - GitHub - balenablocks/browser: A drop-in web browser block

Let us know how you get on!

I had already tried both but to no avail. Thanks though. I guess I’ll keep tinkering

Hi there, out of interest what happened when you tried the browser block on the beaglebone? On its github page it doesn’t say that BBB is supported, but maybe its worth trying anyway? If it doesn’t work exactly, perhaps you could take inspiration from that block/modify it :slight_smile:

Hello @aslansutu I discovered this open issue and I wanted to know if you succeed on this? tested something innovative or you are still thinking how to solve this.

Let’s stay connected

Hey all, sincere apologies for the belated update.

The devices being used were;

  • 1 BeagleBone Black (Rev. C)
  • 1 BBB 4DCAPE Adapter (BB BONE 4D7C 01)
  • 1 Flex cable
  • 1 Display

I went ahead and dusted everything off and gave it a good round of updates just to make sure…well that it is up to date.
With the latest BalenaOS for this device, if I do not have the cape attached, but instead use the mini HDMI to display, I get the classic BalenaOS logo and dmesg’s rolling through. If I run Balena Browser (armv7hf) I believe the xserver takes over the screen because it goes dark, but nothing else. I believe that is another can of worms for another day. However in /dev I can see that the frame buffer (fb0, dri) are loaded.
When I shut down and remove the HDMI, connect the cape and other display and boot, I get nothing. The device does boot up (checked with ssh) however the screen is black (it does get backlit, I’ve also tested the cape, cable, and display with other setups to confirm that it isnt the hardware). Looking through the dmesg I can see that the cape does get recognized, however checking /dev shows no fb0 or dri. I later went and edited the uEnv.txt to;


However, that changed nothing either.

Kernels and overlays aren’t my forte, so I stopped after this.

You just need to disable hdmi since that particular screen have conflicting pins with it.


Also be sure to use correct xorg.conf to avoid color issues: Red and Blue colors are inverted on Beaglebone Black Screen - #2 by ahmet