Used balenaEtcher to load Tails on blank USB. USB drive not showing on computer

  1. Formated my USB drive. Ensured nothing on it. Believed around free 30gbs.
  2. Downloaded Tails Operating System
  3. Ran BalenaEtcher to get Tails on USB.
  4. Showed it all worked (apparently) fine.
  5. But, when I tried to open USB with Tails on it, my computer did not show my USB drive.

I have a relatively new laptop - Maybe 2 years old.
Windows 10.

One last note, when I now insert in my USB in the port, the computer makes a noise that it recognizes I inserted it, but does NOT show on my computer (visually) the drive.

Can anyone tell me how to solve this please.

Thank you in advance.

Take care.

Hi there, since you are creating a bootable USB when flashing an OS using Etcher, that one won’t show up on Windows, since it is not seen as a mass storage device anymore. If you want to flash that OS on your machine, you’ll have to reboot your device and select to boot from USB from your BIOS settings.