Unable to view dashboard - connection refused

I have configured the BalenaOS installer with my network info and flashed to a high quality sd card. I am unable to view the dashboard both locally and via the web link. The error I get states: tunneling socket could not be established: 500

Support access has been enabled. UUID 15a05024dbeaa70948d5684036363502

Fiy, this is connecting to the internet using my phone as a mobile hotspot.

I got home and plugged into the ethernet port. I see the ip address update in the dashboard and I get the same error message.


I think your device is working fine as I just checked and it’s online without any problem. You do not see anything on the dashboard because you have not pushed any application to it yet since I can not find any release on your application.

Please have a look at our getting started guide here https://www.balena.io/docs/learn/getting-started/raspberrypi4-64/nodejs/ as a reference.

This is what I am following

Cool, I think you can start pushing the application to your device now since looks like your device is now connected to balenaCloud and working fine.

Please let us know if you need further support on anything.

This is the result:

balena push GasandEnvironment
Error: no “Dockerfile[.*]”, “docker-compose.yml” or “package.json” file
found in source folder “.”

Found a better tutorial that confirmed my suspicion that the blog post was missing details. Im on a roll now! Thanks!

Hey Josh, can you drop a link to the tutorial you found. We can check it out and see if we need to add more details to our post as well. Glad that things are working out for you.

Step 8 and beyond is what I was missing.

Ahh ok it makes sense, if you clicked the “Deploy with balena” it should have worked following the blog post as well, since that is the preferred way to push when testing out projects, as it avoids cloning the code and tinkering with the command line. Anyhow, great you got it working!

Would you know of an instructional that would show me how to go about attaching a bme680 and a PIM357 to a single raspberry pi?