How to set network requirements

Hello, thank you for reading this newbie post.

I am following instructions on that neat RaspberryPi Zero W train schedule project from chrisys on GitHub. I got it working a few years ago when the 2.4GHz connection problems wasn’t a thing and then tried to start it up again this week to a bit of a challenge… I have since been trying to learn about the wifi changes needed for IoT devices.

Recognizing that the RPi 0 W will not connect to 5GHz, I learned how to split my wifi network to have individual names for the 2.4GHz and 5GHz bands. So I have been trying to connect the RPi to the 2.4GHz band.

Turning on the RPi, after about four minutes the unit shows the 4-flashes error, described here:

At this point the monitor output would show the ASCII BalenaOS logo along with the message, “Booted - Check your balenaCloud dashboard.”

After double-checking the wifi credentials were correct on the SD card, the second piece of advice on the troubleshooting page led me here:
“Secondly check that your network is not restricting or blocking the ports specified in the balena network requirements.”

This is where I falter as a newbie because I kind of understand what is being asked but I don’t know how to do it – how to check what ports are blocked nor how to “allowlist” or “whitelist” something on my network.

My wifi Advanced Settings are currently set to Auto for Channel and 40 for Channel Bandwidth on the 2.4GHz band. Should I specify a channel, and if so, which one and why? (Curious why this could be a thing, as it seemed to help a user in Apr '20 previous posts.)

What do I do to allowlist a domain for multiple ports, or even where to go to check this?

I would appreciate some advice on next steps to try, please & ty.

Did you try to connect you Pi Zero W to another network (e.g. your mobile phone on tethering?) just to discard if the issue is related to the connectivity?

On the other hand, could you please share the balenaOS version that you are trying to use?

Let us know more details about this!


Hi @mpous, thank you for the suggestion.

I connected my phone to the 2.4GHz network and then made it a hotspot. I got another phone to connect to my hotspot to make sure it was visible and working (it was). Then I formatted the SD card, re-flashed it with new wifi settings by going to the Add Device feature in balenaCloud, and booted up the RPi again with the fresh card installed. After four minutes, the four flashes error message happened again and it didn’t connect the device.

I noticed when I formatted the card, it incorrectly sees my 32GB card as a 40MB when it’s going through its default thing.

RE: balenaOS, the img file has the suffix “v14.9.4”. The version I chose when flashing the img to the card via balenaEtcher was 2.113.18 (listed in green as recommended).

@kjec do you have another SD card to try?

To recover the SD card check here on this blogpost → Etcher broke my USB stick … or did it?