Touchscreen remains black after booting

I am new to the balena world.
I run all the installation (PI3 with 7" touch) steps successfully so far.
The Pi is online in the cloud and the services photos, wifi, scheduler and WPE are running.
But my display remains black after booting. I can see a lot of textlines running while booting and suddenly the displays gets dark.
Any ideas?

Hey there!

balenaOS in production mode does not make use of the screen apart from showing the boot logs and splash screen as you mentioned. You may configure your application container to take control over the screen, or provision the device with a development balenaOS image, which should present you with a login prompt.

The reasoning behind this is that Balena users should very rarely need to login to the host OS, and focus on the application container instead.

Thank you for the quick response.
I have a development image running. I also added a variable “WPE_URL” to show a website. The screen still remains black.
I can even access the raspi on port 8080 an enter a URL. Still the same. Display shows nothing.

Are you using balenaDash or have you build your own project? The balenaDash project ( sound very similar to your project.

I am using balenaDash. Followed exactly all the instructions in your link.

I just learned there is a conflict with the balenaDash project and the lastest balenaOS version. So the project won’t work at the moment on 2.41, you would have to use balena OS 2.38.

Thank you so much. That was helpful. Set up OS2.38.
Now everything is working.