System Rescue CD: "It looks like this is not a bootable image."

I am trying to burn a System Rescue CD flash drive. Just moved over to Etcher from another disk creator, and so far I love Etcher, but it doesn’t seem to get along with the System Rescue image for some reason.

Any ideas?

Have you tried using the “continue” option to see if the image still writes correctly?

Also, looking at the System Rescue CD page, it looks like there are some extra steps that you would need to take to make the image something that you could boot from a USB stick (as the image itself is intended to boot from CD which has a different process). Did you take those steps on the image first?

Goodness, I had never even gone through those instructions…

I used to fix the ISO so it would work with Etcher, than it worked like a champ. I don’t know how often people run into this with other ISOs – would it be a good idea to integrate isohybrid into Etcher? Other disk creators that I had used to create System Rescue CD bootable drives seemed to do it automatically (hence I didn’t know about the requirement).

Thanks for answering!