Bootable ISO won't boot off of SSD

Seems like this issue has happened to others here on this forums, however it was a few years ago. Wanted to post what I’m experiencing.

We have a Red Hat Enterprise Linux 7.4 ISO, and we want to boot off of this ISO from an SSD, which is 1.9 TB in size.

I know the ISO is good, as I can boot from it a VM in Virtualization Software (QEMU/KVM).

I’ve tried to use Etcher to place this ISO to the SSD Drive. When I select the ISO, I get this error:

It looks like this is not a bootable image. 

the image does not appear to contain a partition
table, and might not be recognized or bootable by 
your device

Also the SSD Drive is not detected either by Etcher. I’ve had the drive mounted either via a hard drive sled or a USB to SATA connection converter and Etcher still doesn’t see it. I can see the SSD from the OS (Red Hat) with no issues.

This is the error message that I get:

connect a drive!
no removeable drive detected 


We have a couple questions:

  • What version of Etcher is running?
  • Is the drive connected externally or internally? If it’s an internal drive, it should be available by showing hidden targets in the target selector, but be careful because it lists all the internal targets, including system drives where the OS is installed or any other “data” additional drive.

Latest and greatest version: 1.5.45-x64.AppImage

I’ve tried it both ways. I’ve tried it when the SSD is mounted internally into the Workstation via a Hard Drive Sled. When it didn’t work. I tried to use a USB to SATA connector and still the same results.

Not sure what you mean by showing hidden targets.


Hi, When you open the select target dialog in etcher you should see a line offering to show hidden devices. Those are devices etcher does not recognize as removable. But be careful as this allows you to flash internal devices that are neccessarry to run your system.

Not seeing any hidden devices from the UI, unless I’m doing something incorrect. Here are the screenshots that I’m seeing.

EDIT: I’m only allowed to upload one pic since I’m a new user. I have two other pics that I want to upload to show what I’m doing.


Hello @19rellimcm37

This version is a bit old, you can get a newer release from here .

What operating system are you using ?

About the drive not being detected, could you please provide the output of lsblk --bytes --all --json --paths --output-all ?

The OS I’m using daily and trying to use Etcher on is RHEL 7.4 with 3.10.0-693.el7.x86_64 kernel.

I’m downloading balenaEtcher-1.5.109-x64.AppImage currently, as I downloaded the previous one directly from balenaEtcher website.

I downloaded the previous one directly from balenaEtcher website

That’s likely because javascript is disabled for the balenaEtcher website, which prevents fetching the latest version and instead falls back to v1.5.45.

Let us know how it goes with v1.5.109

I keep getting the following error when trying to select the iso: “Missing partition table. It looks like this is not a bootable image. The image does not appear to contain a partition table, and might not be recognized or bootable by your device.”

I select the SSD drive, kick off the process and it was successful.

When trying to boot off of the drive, this is the error message that I’m getting: “Reboot and select proper boot device. Or insert boot media in selected Boot Device and press a key”

I did setup on the SSD a boot sector (MSDOS) and formatted the free space FAT32.

ISO images are not required to have a partition table, but a partition table is required when booting from non-optical media. You can run the file command on that RHEL 7.4 image to check whether it has a partition table or not. For example:

$ file archlinux-2020.10.01-x86_64.iso CentOS-4.2-x86_64-bin1of4.iso
archlinux-2020.10.01-x86_64.iso: ISO 9660 CD-ROM filesystem data (DOS/MBR boot sector) 'ARCH_202010' (bootable)
CentOS-4.2-x86_64-bin1of4.iso:   ISO 9660 CD-ROM filesystem data 'CentOS 4.2Final x86_64 disc1' (bootable)

Both are valid ISOs that can be burned and booted from CDs, DVDs, and BDs. Virtual machines should also be able to boot from either. However only the archlinux ISO in this case can be flashed and booted from non-optical media because it contains a partition table, unlike the CentOS ISO.

Furthermore, the flashing process rewrites any partition tables in the target device. If the original ISO does not have a partition table, the flashed device will not have them either.

AFAIK, RHEL images should have a partition table unless yours was burned from a physical CD/DVD.

1 Like

Great info, didn’t realize the file command would show this info (probably never ran it against an ISO)

Now I downloaded the same archlinux ISO directly from their website and I’m not seeing the (DOS/MBR boot sector), like the example you give above. Matter of fact, I don’t see that on any of the Linux ISOs that I’ve downloaded.

So, I’m not sure how to create a DOS/MBR boot sector partition and a quick online search doesn’t show any processes on how to create this.


HI, what link are you using to download it from? I just tried and it does contain a partition table:

file archlinux-2020.10.01-x86_64.iso
archlinux-2020.10.01-x86_64.iso: DOS/MBR boot sector; partition 2 : ID=0xef, start-CHS (0x3ff,254,63), end-CHS (0x3ff,254,63), startsector 264, 114688 sectors