Support for AAEON

am I correct that AAEON boards ( ) are not supported?


Hi @banto-78,

We’re working on adding support for this device but I’m not sure when it’s released yet, I will pass your question to our devices team and will get back to you as soon as possible.

1 Like

Hi. This board is supported. You can use the Up Board OS for this board and it will work as expected.

Many thanks. Just to be sure i understand. what you mean for " Up Board OS" ?

Are you using images or images?

Ok sorry, you meant “UP board BalenaOS 2.29.2+rev1” , right? Between: we would like to use balenaCloud for download and link to our Cloud account…

So if you are using balena cloud, then you should be able to select Up Board in the dropdown when you create a new application and then download the OS from there and it can be used on an Up Squared board.

Many thanks! Alternatively I understand we need to download the OS, use the local mode and then with CLI we join the device to the Cloud, right?

Alternatively you mean in case you download the image from ?


You can use local mode on cloud OS also, you just need to use a development version to be able to enable local mode from the dashboard. And please note that development images should not be used in production environments, they should only be used while you develop your product on test machines.


I tried to install Balena on AAEON UP Squared board but I cannot see my device connected to the BalenaCloud.
I followed the instructions here:

After waiting few minutes, I cannot see the device connected to the Wifi AP.
How can I be sure that the process is done, since I don’t have any visual information that tells me the flash is completed? (I cannot see the LEDs blinking or not)


Have you tried connecting the device via ethernet? Could you post a link to your application on balena cloud and enable support access please?

Sorry but ethernet is not an option, only wifi is available.
Do I need to Grant Support Access ?

Yes, if you could grant support access that would be great


I can’t see anything out of the ordinary with your application setup.

  1. Have you removed the USB drive you used to flash the device?
  2. Do you still have the device connected to a monitor? If so is anything shown on the screen?

I retried to do the process one more time and now I can see on the monitor
“Booted - Check your balenaCloud dashboard”

But I still don’t see it on the dashboard

It seems the device doesn’t connect to the wifi. I don’t see it in the list of connected devices of the wifi.

On flash-boot/system-connection I have:


ssid=my ssid




You could remove the field hidden=true from the wifi section and try again… I recall that we had issues with that in the past on some device / network combos.