Successfully loaded and tested 1st app (node) but can't load 2nd app (resin-wpe)


I have local git resin/simple-server-node set up. Now cloned wpe-resin into resin/resin-wpe. Tried to push it to server:

git push resin master

! [rejected] master -> master (non-fast-forward)
error: failed to push some refs to '**/wepapp.git’
hint: Updates were rejected because the tip of your current branch is behind
hint: its remote counterpart. Integrate the remote changes (e.g.
hint: ‘git pull …’) before pushing again.
hint: See the ‘Note about fast-forwards’ in ‘git push --help’ for details.

What am I doing wrong and what should I be doing?


Are you saying that you have an application running simple-server-node, and you’d like to run resin-wpe on it instead? This is just a git issue you’re seeing, since you’re trying to push commits that aren’t part of the tree on the remote. Using git push resin master -f should work. The -f flag will force push to the remote. WARNING: Using force pushes will PERMANENTLY overwrite the code on the git remote, so don’t use it if you have any remote code with resin that isn’t stored elsewhere.


Thanks Jack. Yes, problem solved by using -f. Can you only have 1 app deployed at a time on each target device? What if I wanted both apps (node and wpe) to be available to run?


Can title be edited to add: ‘[solved]’ ?


We currently only support one app per device, but we’re working on multi-container support. I’ll update the title.


Ah right, I don’t think that is made sufficiently clear in the documentation.