Stuck the moment I pressed flash and I accepted the admin rights


#1

I got etcher protable 1.4.6 x64 and I run it without admin rights, put an iso selected usb pressed flash and admin rights dialog poped I accepted and it stuck.


#2

Just start it with admin right by default, I too had permission issues on linux but then I started it with sudo and everything worked like a charm.


#3

I am just bringing this up so it can be fixed, why should I run it as administrator, if it needs admin rights it should ask by the way i am on windows portable etcher


#4

According to Windows permission system, you should have the ownership of the drive/folder/file you try to edit, by default only administrators can format drives/devices, that is why you should first change either the permissions to access your drive or start Etcher with privileged account.

I can’t help you with knowing why Etcher doesn’t ask for permission first


#5

it asks for permission. the thing is that it didnt work, it got stuck.

what I did

first try:
1 running etcher protable normaly 2 selecting iso 3 selecting usb 4 clicking flash 5 asks for admin rights 6 it gets stuck.

second try:
1 running ercher with admin right 3 same 3 same 4 same 5 success.

so the issue I am reporting is that there must be a bug if you run without admin rights etcher then accept the admin rights it requests and then getting stuck.

another question that hit me, where do I report a bug, cause you dont sound like balena support.