Sound Supervisor won't start / Spotify issues

Update: I posted this topic like a month ago, but got no replies and I also gut no further replies from the staff on my original post. I would really appreciate helpful replies, because I am trying to get this to work for so long…

Hello, I recently posted here and made some progress with my system, but there are still problems. I deployed balena sound to my raspberry pi zero 2 (+ HIFI DAC Zero). The previous deploys didn’t work because the wrong version of docker was used. This was fixed, so now the sound supervisor installed without a problem. I tried to play music via spotify connect and BT but nothing worked. The terminal output continuously stated "

When I try to connect to Spotify and play a song it disconnects immediately. The logs are as follows:

spotify [2021-12-23T12:33:56Z INFO librespot_playback::player] Loading <Walk This Way (feat. Aerosmith)> with Spotify URI spotify:track:6qUEOWqOzu1rLPUPQ1ECpx
spotify [2021-12-23T12:33:57Z INFO librespot_playback::player] <Walk This Way (feat. Aerosmith)> (310386 ms) loaded
spotify ALSA lib pulse.c:243:(pulse_connect) PulseAudio: Unable to connect: Connection terminated
spotify [2021-12-23T12:33:58Z ERROR librespot_playback::player] Audio Sink Error Connection Refused: Device default May be Invalid, Busy, or Already in Use, ALSA function ‘snd_pcm_open’ failed with error ‘ECONNREFUSED: Connection refused’
Service exited ‘spotify sha256:b354887709a46e467701c9ea0ed1b59060e155973f9e65a25835d8b801c21de1’
audio Waiting for sound supervisor to start at
Restarting service ‘spotify sha256:b354887709a46e467701c9ea0ed1b59060e155973f9e65a25835d8b801c21de1’
spotify Starting Spotify plugin…
spotify Device name: balenaSound Spotify 1738
spotify Volume normalization enabled.
spotify Spotify audio cache disabled.
spotify [2021-12-23T12:34:01Z INFO librespot] librespot 0.3.1 bbd575e (Built on 2021-11-26, Build ID: a6e0Ery3, Profile: release)
spotify [2021-12-23T12:34:01Z INFO librespot_core::session] Connecting to AP “
spotify [2021-12-23T12:34:01Z INFO librespot_core::session] Authenticated as “1155180833” !
spotify [2021-12-23T12:34:01Z INFO librespot_playback::mixer::softmixer] Mixing with softvol and volume control: Linear
spotify [2021-12-23T12:34:01Z INFO librespot_playback::convert] Converting with ditherer: tpdf
spotify [2021-12-23T12:34:01Z INFO librespot_playback::audio_backend::alsa] Using AlsaSink with format: S16
spotify [2021-12-23T12:34:01Z INFO librespot_core::session] Country: “AT”

When I try to pair my phone with the BT of the Pi it won’t work either.

I alqready set the variable “AUDIO_OUTPUT” to “DAC” and the custom config. “BALENA_HOST_CONFIG_dtoverlay” to “hifiberry-dac” because I’m using the hfiberry zero dac.

In case you need the .log file, I attatched it to this post.
log.txt (7.3 KB)

Any ideas? Thanks in advance!

I also granted support access for one week!

I’m not sure if this will be relevant to you, but I’ve been trying to set up BalenaSound on Rasp 1 B+ and it seems that they can’t handle all services running, as of now I’m attempting to run or install BalenaOS on docker or a VM and have that set up as Master and my pi’s as client-only which I hope will work.

Thanks for your reply :slight_smile: Good thought, but it seems to me that it‘s a configuration / deployment problem because everything runs smoothly (Pi Zero 2 WH is a recent model with sufficient hardware).

Good luck with your setup!