Raspberry Pi Zero 2 - Sound Supervisor does not start / Spotify does not work

Hello, I recently posted here and made some progress with my system, but there are still problems. I deployed balena sound to my raspberry pi zero 2 (+ HIFI DAC Zero). The previous deploys didn’t work because the wrong version of docker was used. This was fixed, so now the sound supervisor installed without a problem. I tried to play music via spotify connect and BT but nothing worked. The terminal output continuously stated "

When I try to connect to Spotify and play a song it disconnects immediately. The logs are as follows:

spotify [2021-12-23T12:33:56Z INFO librespot_playback::player] Loading <Walk This Way (feat. Aerosmith)> with Spotify URI spotify:track:6qUEOWqOzu1rLPUPQ1ECpx
spotify [2021-12-23T12:33:57Z INFO librespot_playback::player] <Walk This Way (feat. Aerosmith)> (310386 ms) loaded
spotify ALSA lib pulse.c:243:(pulse_connect) PulseAudio: Unable to connect: Connection terminated
spotify [2021-12-23T12:33:58Z ERROR librespot_playback::player] Audio Sink Error Connection Refused: Device default May be Invalid, Busy, or Already in Use, ALSA function ‘snd_pcm_open’ failed with error ‘ECONNREFUSED: Connection refused’
Service exited ‘spotify sha256:b354887709a46e467701c9ea0ed1b59060e155973f9e65a25835d8b801c21de1’
audio Waiting for sound supervisor to start at
Restarting service ‘spotify sha256:b354887709a46e467701c9ea0ed1b59060e155973f9e65a25835d8b801c21de1’
spotify Starting Spotify plugin…
spotify Device name: balenaSound Spotify 1738
spotify Volume normalization enabled.
spotify Spotify audio cache disabled.
spotify [2021-12-23T12:34:01Z INFO librespot] librespot 0.3.1 bbd575e (Built on 2021-11-26, Build ID: a6e0Ery3, Profile: release)
spotify [2021-12-23T12:34:01Z INFO librespot_core::session] Connecting to AP “ap-gew1.spotify.com:4070
spotify [2021-12-23T12:34:01Z INFO librespot_core::session] Authenticated as “1155180833” !
spotify [2021-12-23T12:34:01Z INFO librespot_playback::mixer::softmixer] Mixing with softvol and volume control: Linear
spotify [2021-12-23T12:34:01Z INFO librespot_playback::convert] Converting with ditherer: tpdf
spotify [2021-12-23T12:34:01Z INFO librespot_playback::audio_backend::alsa] Using AlsaSink with format: S16
spotify [2021-12-23T12:34:01Z INFO librespot_core::session] Country: “AT”

When I try to pair my phone with the BT of the Pi it won’t work either.

I alqready set the variable “AUDIO_OUTPUT” to “DAC” and the custom config. “BALENA_HOST_CONFIG_dtoverlay” to “hifiberry-dac” because I’m using the hfiberry zero dac.

In case you need the .log file, I attatched it to this post.
log.txt (7.3 KB)

Any ideas? Thanks in advance!

Hey Lukas,

Apologies for the late reply.

It seems you have several posts for the same issue.

I checked the logs, but unfortunately, there are not clues as to why the sound-supervisor is not running.

Can you please help with the following:

  • what version of balenaSound are you running?
  • what version of balenaOS are you using?
  • can you please enable support access or provide some more detailed logs?


yeah, I have several posts about the same problem, because I didn’t get any help, so I thought it would get more attention.

I searched for the requested information and tweeked some settings, and now it’s working!

Thank you for your reply :slight_smile:


Thanks Lukas - great to know it’s now working, do have any idea what exactly fixed it? That way we can help others in the same situation.


Unfortunately I don’t exactly know what fixed the issue, but I think I tried multiple deploys and releases. The problem is, that I’m not that experienced with the software to exactly explain which steps helped to fix this problem.

Kind regards,

I think I’ve also tried different versions of sound supervisor, but my guess is that internal updates / bug fixes overall helped solving my issue.