Sound cuts out in Bluetooth receiver project, Pi 3

Experiencing regular sound cutting off when using bluetooth project suggested here:
[https://www.balena.io/blog/turn-your-old-speakers-or-hi-fi-into-bluetooth-receivers-using-only-a-raspberry-pi/]
I’ve tried disabling wi-fi (as suggested on other similar project pages, but this seems to have no effect - although I don;t know how to check whether wifi is actually off.
I added a new DEVICE CONFIGURATION variable, ‘RESIN_HOST_CONFIG_dtoverlay’ and set its value to ‘pi3-disable-wifi’ but dont know how to check whether this had any effect.
I’ve also tried disabling bluetooth by setting value to ‘pi3-disable-bt’ and plugging in a bluetooth dongle, but this just generates lots of errors in the log window.#
Can anyone suggest a possible fix to this, please? I’m semi-competent with Pi but do need simple, clear instructions to guide me.
Without a fix this glitch is just too annoying to live with.
I would buy a dedicated bluetooth receiver for my stereo but I felt that re-purposing a Pi 3 would be more appropriate and allow me to stream via a DAC slound card that I am going to add to the Pi (if I can fix the sound issue).
Thanks in advance.
Nibbos

Hey @Nibbos and welcome to the forums!

What device are you using to stream to the Pi? Have you tried other devices to see if they exhibit the same issue? Do you have any other bluetooth devices in the immediate vicinity?

What you’ve done to disable the WiFi should work fine, one way you can confirm this is by running ifconfig in a hostOS terminal; you should see the wlan0 entry disappears when you add that configuration variable.

I’ve tried Galaxy S7 phone and Amazon Alexa, both of which work fine on all standard Bluetooth speakers.
I have a Bluetooth dongle from an older Pi B project but when plugged in to the Pi 3 I got a whole stream of error messages in the log window on the balena dashboard.
Thanks for response so far.

When you say the sound cuts off, what is actually happening? Does the audio stream go completely silent for a period of time, or is it more like interference?

Sound plays for 20-30 seconds, cuts out for 1 or 2 seconds, plays for another 30 seconds or so, cuts out for 3-4 seconds. This continues. Sound isn’t pausing during cutout, but is just silent for that time. This has been widely reported, even in the question section of the project page itself. But no answer has been forthcoming as yet.
Thanks again for swift response.

I’m not sure what more we can do here but please could you create a Github issue on the project repository, nobody else has reported this issue there so far, but that would give it maximum visibility and other project contributors may be able to help.