Simpler steps for deploying Jetson Orin Nano 8GB (SD) Devkit NVME

I am having trouble setting up Jetson Orin Nano 8GB (SD) Devkit NVME.

The steps outlined in Balena Cloud seem quite complex and tell me to insert an NVME. I am not using an NVME, but rather just an SD. From what I understand, this should work.

Are there any simpler steps for deploying a Jetson Orin Nano 8GB (SD) Devkit NVME?

I tried just flashing the image from Balena Cloud to the SD and inserting into the Jetson, but it did not work (it never connected to Balena).

1 Like

I am facing the exact same issue. Would appreciate anyone helping out on this!

This video that Balena support provided to me helped: Balena support recommended using an NVME (although they didn’t explicitly say that an SD card wouldn’t work). I used an NVME, followed the steps in the video, and it worked.

1 Like

Hi Tim :wave: thanks so much for sharing! Do u mean that you bought additional NVME and place it at the back of the devkit for this to work?

Yes, my devkit did not come with an NVME, so I bought one.

is there a reason why an NVME is required? I’m hoping someone from the balena team could help answer. Or is there a way where we can flash balenaOS onto Jetson Orin Nano 8GB without using NVME?

also, for the host PC in the instruction, does it needs to be of specific CPU architecture / OS? I’m currently using macOS Sonoma 14.1.1 (arm64) M1 chip.

an update on my deployment, so that other people can benefit. I did followed the steps from the youtube link Tim posted here, and it worked!

My setup:

  • jetson orin nano nvme devkit
  • bought the cheapest nvme and installed it on my jetson orin nano
  • host machine is an ubuntu 22.04 (x86) machine
  • used a USB stick to flash instead of SD card

I’m still unsure why an NVME drive is required instead of relying on SD card.

1 Like