Screenly Ose running on Balena - after upgrade asset not showing


I have run Screenly Ose on Balena succesfully earlier. Now I upgraded to release 61cb3e6. Upgrading went well and all assets ( web pages, jpg images, videos and youtube videos) are running correctly but one asset ( ) is showing white page and log shows this image unable to get git branch and latest version from github

Then I flashed only screenly ose to memorycard and that page is working on in correctly on that but not with balena.

I have new class 10 fast memorycard…

So any help where might be the problem in Balena

Hello @Jaakkoo thank you for your message.

Did you install it from or from the github repository?


First with github as upgrade as I had old release in balena where everything worked but when that problem came I made new application where I used hub.balena and then upgraded it because it was a breeze. Same proble with github, hub.balena breeze and upgrade of hub.balena.

It works without balena, but I have other Pi’s in balena so it would be good to have all in same place.

@Jaakkoo that’s really odd! Looks like there is a difference on git repositories to me! Could you please grant me support access to your device?

And maybe @vpetersson can help here or you can jump into this? or suggest if this should be handled on the Screenly OSE forums maybe?



So how I grant you a access…is it just grant support access from balena application?

Could you please give more details on what device are you using, and the installation workflow? where do you get the name of the release 61cb3e6? Thanks!

Here I done it again today.

From I deployd with balena.
Then added device raspberry pi 3 ( I have raspberry pi3+B)
I flashed it with etcher. Put the card into Pi then it is ready but not working with that one https page.
Then I dowloaded zip file from github/screenly ose
With gitbash software I login to balena ( balena login)
from the unzipped folder location with command: balena push [appname]
Then I get unicorn and info that it build succesfully.

Then in the balena I notice that it has now release

But that one page is not working…all other pages etc works

Hey @jaakkoo,

Thanks for the patience here. We’re curious about this issue and are taking a closer look. I actually replicated your same issue with a Raspberry Pi 4 and encountered the same white screens. Still investigating!

Just in case we can get a quicker answer at what might be going on with this recent Screenly release (61cb3e6), let’s cc @vpetersson (the Screenly maintainer). Any ideas here?

Just to confirm, @jaakkoo: when you say that everything works without balena, is that with the latest Screenly release? We just want to make sure we have all our info in place as we investigate. Thanks ahead!


Good to hear that there might be something wrong and I’m not only doing something wrong.

Yes If I dowload lates image from GitHub - Screenly/screenly-ose: The most popular digital signage project on Github!

And I flash it to memorycard with Etcher and put card to Pi3B+ everything works, no white screen.

Hi again,

I spoke briefly to Viktor from Screenly and he said that he would try and take a look at this when he gets a chance. There has been a lot of updates recently to the inner workings of Screenly OSE so it is possible this could have introduced some bugs. It is interesting that it works on some web pages but not others though.

From what I can tell the GitHub errors are coming from these lines of code:

It seems that it is trying to get a viewer update from GitHub and failing. However, I am not sure that is the root cause of the issue with the web page not displaying and that might be something different altogether.

Do you get any other error messages in the command line at all? Or these are the only ones?


P.S. the issue is also being discussed here in a GitHub Issue on the Screenly OSE page:


No, I don’t see any another error messages. It seems to work although…only that white page…I noticed that if I restart pi then it tries to open that page, it shows one second that page and then white page.

I noticed also now that if Google slides webpages contains object animation (fading, distancing, zoom in/out etc.) are not showing properly. 10 second slide is showing 5 seconds and then 5 second white page. But if slide is still slide it is ok then. This is something to do with object animation…as in my original webpage contains news with object animation. Problems with rendering pages…Is this helpful to find root cause.

Is there a command that I can use to find errors?

Hi everyone,

I have reproduced this. Looking at, I think it is far too heavy on the JavaScript for the Pi to handle. Try removing all/most of the animations and see if that makes it work.

With regards to installing Screenly OSE on Balena, the recommended way is outlined here. This is a workaround as it’s not possible to pass on the necessary variable using the git push balena master method. The script referenced in the documentation solves that.

Btw, just for the record. The reason why you’re getting Unable to get latest version from GitHub and Unable to get Git branch is because the environment variables are not set (these are set by the script mentioned).


This page is not mine…it is national news broadcast co. and it has worked earlier…and it works without balena with screenly.ose and Pi

@jaakkoo can you try the installation method @vpetersson mentioned. It contains a deploy script which will set the correct configurations so you do not see those github errors. screenly-ose/ at master · Screenly/screenly-ose · GitHub

After you do that can you run your device and if the screen is still white SSH to the hostOS and run top to see what the memory/cpu usage is and report that back.