RPi4 Image Completely Broken/Useless And Not Worth Trying

So I was using RPi 4 when nothing worked surprisingly, everyone else on the forums is also complaining about how the images aren’t working, I feel like they rushed to make this and didn’t spend any time for the images, the issues are:

  1. It goes offline after 5 mins randomly

  2. It downloads the image but doesn’t do anything with it

  3. I haven’t seen a single working RPi 4 folding

  4. Even the official FAH/F@H dev team hasn’t made anything that works on RPi4(I tried and it didn’t work)

  5. I reimaged 5 times so it isn’t an issue with the card

  6. I also swapped the card once and still doesn’t work

  7. The URLs are completely useless, doesn’t work 100% of the time

  8. You need a fan or it will get too hot and short your RPi, I learned this the hard way

9 and so on. I also feel like this is useless, I use the official FAH/F@H software on my windows and it calls 2.3GHz “Light Mode” Whereas the “Medium Mode” is around 6.9GHz and full depends on your setup, and the ram usage is 4.5 GB on average on “Light Mode”, Which means out RPi’s are barely doing anything helpful, there are also people saying that this is all a big scam and this is “Helping People Grow Rich”

I highly suggest using the official FAH/F@H software on your Main Computer because you can set it so it runs when you’re idle or even when your working, it can also be used on a lot of platforms, they also say that it works on RPi but it hasn’t for me, I suggest if you’re having trouble with the image or anything really that isn’t working it probably won’t help if you reimage 99 times over.

I really do hope that the Dev team at Balena can fix this issue because if this is also giving false results then it is a bigger issue, I would also like to see if the dev team even tested this, it seems unlikely that they have all those different single board comps and comps, I really want to see them even just release a video on if this even works, the official FAH/F@H team actually even have tutorials whereas Balena doesn’t. In fact, they don’t even have a support system and just direct us back to other people with the same issue which I think is hilarious. They also say that the “idea” is to make it a simple “insert sd and forget” though it would be nice if they realized that it wasn’t doing anything.

I also think that I never agreed to anything of being on the “map” that they have so I think that the map is fake if it is hidden in the tos or pn then nobody really reads that and that can lead to some issues legally.

Is it me or did I see the number go from 3k(yesterday) to 2k? And it stayed around the same number since?

Overall, just don’t try this, if you want to help with folding, just go to the offical https://foldingathome.org/ website and help there, they support many more platforms and is better since you can actually control what you help with, and see what your helping with.

Hi there, sorry to hear you are having some difficulty, but let me clarify a couple of points that may be causing some confusion. First and foremost, this is not the Folding@Home project (FAH). This is Rosetta@Home, which is an entirely different project, led by an entirely different group. The FAH devs have not produced anything for the Raspberry Pi 4, because at the moment of this writing, FAH does not support the Arm SoC on the Pi 4 (that may change in the near future, as I know some efforts are underway there). So, for clarity, if you are in fact attempting to run Folding@Home, I do fully agree that it won’t work. Assuming you have not altered the image, then, Rosetta@Home does work, and successful results are showing here: https://boinc.bakerlab.org/rosetta/hosts_user.php?userid=2085224

Second, I do watch the map very closely, and can ensure that the number was not 3,000 units yesterday, and has not decreased in any significant way. We have been adding about 100 to 200 devices per day, rather steadily.

Third, and probably most importantly, what type of Raspberry 4 are you using? Is it a Pi 4 with 1gb of memory? Because the majority of protein folds actually require 1.9gb of memory, so unless there are small simulations to be run sitting in the work queue, a 1gb device will not pull any work units for processing. This is documented, as part of the Frequently Asked Questions, but many users seem to still be missing it, so perhaps we can move that information to a more prominent location.

Finally, we do also have a list of Issues we are working though in the open, publicly available on GitHub, located here: https://github.com/balenalabs/rosetta-at-home/issues. As an open source project, you are welcome to open Issues pointing to any specific errors you receive, and, Pull Requests are welcome.

Hope that helps clarify a few things, thanks.

I’m using the RPi 4 with 2gb of memory with a rather good 64gb A1 class 10 micro sd with active cooling and heatsinks now, but I’ll try again to flash it and see if it still doesn’t work, it’s really a mystery on how it works on some RPis but not others, also on Windows there is a thing called readyboost where you can use it on any external storage and use that as ram? I was wondering if there was a way to implement that onto this image. Also, last fact, it might actually work but the issue for me is that it downloads the proteins, then stops computing and starts “running cpu benchmarks” but it does that for about 24 hours already and nothing has changed, is it actually running bench marks for 24 hours or is it broken/stuck?

If the benchmarks were designed for desktop computers and not sbc’s, then that is why it is taking so long. Imagine having a PC with 64GB HD, 2GB memory, and 1.5Ghz CPU…that would be a very low-end PC, and so I would imagine that the benchmarks are still running, or have corrupted the memory stack with an overflow or similar.

You can check for core.dump files on the root folder of the device to see if that last item is true.

@Tet we also made some changes to the application last night (around 1800 UTC) that benefit lower memory (<2.5GB) devices. The reason why some devices appear to work fine and not others is simply because they are not doing the same work; the work packages that Rosetta distributes have different memory requirements and perform different calculations - two devices side by side deployed at the same time would not necessarily be doing the same job. In our testing we found that some work packages will work fine on a 2GB device but others will cause it to crash/reboot. In the latest update (yesterday) we reduced the default memory consumption for the BOINC client to 95%, which in testing has allowed <2.5GB memory devices to remain stable in a greater number of cases. We will continue to monitor this and refine the configuration to ensure all devices are contributing as much as they can.

I would guess at what’s happening in your case is that the actual processing tasks are consuming all of the resources and not allowing the UI to function and update correctly, meanwhile the work is happening in the background. Again, this should be better in the latest update.

The aim of Fold for Covid is to enable as many people and devices to contribute with the least effort possible. We want to give everyone the chance to help. If you feel that you can contribute more efficiently with F@H or by running Boinc/Rosetta on a desktop, by all means do so - ultimately any help in any of these projects helps the cause; we’re all pulling in the same direction here. Meanwhile our team made mostly of Raspberry Pis is up to 44th place in terms of contribution, so I don’t think it’s wasted effort at all; a lot of small contributions goes a long way - well done team! :partying_face: https://boinc.bakerlab.org/rosetta/top_teams.php?sort_by=expavg_credit&offset=40