Install image issues on a laptop(s)

I’m having issues installing the Generic x86_64 image on a spare laptop. I have tried two(2) laptops with no success. It appears to be a graphics issue . The first loads till the the text graphics size changes and then its just garbage and lockup. The second actually loads the image but the graphics image and text are duplicated on the screen. So I need a little direction on what to try.

Dell Precision M65 and HPDV2500se

I was successful with a Rpi 3+ and its working fine. Thanks for any help


Edit- the HP actually loads the the system and starts to process a task. You can see bits and pieces of the foldforcovid processing screen. The display is really messed up.

Maybe it is a driver issue ? I don’t know how it is made, but some generic driver should be available and may not seem to work with your laptops.

On my MSI GP60, the keyboard is not working, so I suppose it comes from that.

But if you go on foldforcovid.local to reach your laptop with web-browser, does everything display/compute well ?

Yes it was a graphics driver issue. I just loaded ubuntu on the M65, updated the graphics driver, installed Boinc and it works fine. My Rpi 3+ with 1GB is worthless and took it off. Did install Boinc on a Win 10 and it has become the champ of the group. Never could get foldforcovid.local working on the Rpi but just putting in the IP address in a browser worked fine. So everything is working good. Stay safe…