rPi 2 Won't Boot - 7 flashes

Hey there -

I’m having issues getting my Raspberry Pi 2 to boot. I’ve tried all 3 of the supported Dev & Prod versions - 2.43rev1, 2.38rev1, and 2.36rev2. I even tried the earliest available - v2.12.3 and keep getting the same kernel error (7 blinks of ACT) each time. I’ve tried multiple SD cards and have used the same SD cards w/ Raspbian before and after imaging them w/ balenaOS and it’s booted up just fine. I’m using Etcher for both balenaOS and Raspbian.

The last image I tried before giving up was v2.12.3:

$ cat os-release 
NAME="Resin OS"
PRETTY_NAME="Resin OS 2.12.3+rev1"

My board doesn’t have the version written on it, but after booting to Raspbian, here’s the version from /proc/cpuinfo:

$ cat /proc/cpuinfo 
processor	: 0
model name	: ARMv6-compatible processor rev 7 (v6l)
BogoMIPS	: 697.95
Features	: half thumb fastmult vfp edsp java tls 
CPU implementer	: 0x41
CPU architecture: 7
CPU variant	: 0x0
CPU part	: 0xb76
CPU revision	: 7

Hardware	: BCM2835
Revision	: 000f
Serial		: 000000002fb82ab3
Model		: Raspberry Pi Model B Rev 2

I also ran an rpi-update just in case this was some sort of issue w/ my really old firmware.

What am I missing? Please halp! =)

Hi @kleintech

From the info you posted, I’m pretty sure you have a RPi 1, not a RPi 2 (Raspberry Pi Model B Rev 2 should simply indicate it’s Rev 2 of the Raspberry Pi 1 Model B). Can you please try using the recommended balenaOS version for Raspberry Pi (v1 / Zero / Zero W), and let me know if the problems persists?

However, to download this image you will need to create a new application first, selecting Raspberry Pi (v1 / Zero / Zero W) as the device type for the application, since it uses a different architecture from RPi 2 - our systems are optimized for the specific hardware.

Kind regards

1 Like

Perfect! Thanks Alida! I was under the impression that the “Rev 2” meant it was a 2nd gen rPi.