Raspberry pi zero W is locked, can you help?


We have a Raspberry Pi Zero W deployed at a client site that is locked and cannot be updated, log keeps printing the following

Killing application ‘registry2 .resin.io/…’
Failed to update application ‘registry2 .resin.io/…’ due to ‘[object Object]’

Restarting/rebooting the device doesn’t help. We also tried just about anything with the Supervisor remote API, again no luck. The device is running Supervisor version 6.1.2 so I suspect it may be related to this problem.

It’s almost impossible to go to the client site and replace the SD image, also even if we do this the same error may appear again.

We’re a IoT startup that has just launched our pilot programme, with live installations in a couple of different clients so having access to our devices is really important at this stage. If all goes well, we’d like to use resin.io for all our device fleet.

Is there anything that you can do remotely to help us get past this error?
I’d appreciate this a lot.


Hi Alex,

Could you send me the dashboard link to the device and open the device for support access? This can be done in the dashboard in the actions panel.


Same error I am getting…I am in a similar position and have been for two+ weeks…can’t deploy my app

Hi everybody. We have released version 2.7.8+rev1 for the raspberrypi 1, raspberry pi zero and raspberrypi zero wireless.
This release should fix the above mentioned problem. Can you update to that version and let us know if you still see this issue?

updating now…thank you @floion

You are welcome. Let us know how that goes

Same error :

19.12.17 09:58:40 (+0800) Installing application 'registry2.resin.io/someapp/hashywashyhashingmashing'
19.12.17 09:58:41 (+0800) Installed application 'registry2.resin.io/someapp/hashywashyhashingmashing'
19.12.17 09:58:41 (+0800) Starting application 'registry2.resin.io/someapp/hashywashyhashingmashing'
19.12.17 09:58:47 (+0800) Failed to start application 'registry2.resin.io/someapp/hashywashyhashingmashing' due to '[object Object]'
19.12.17 09:58:47 (+0800) Failed to update application 'registry2.resin.io/someapp/hashywashyhashingmashing' due to '[object Object]':

Hi @pcarranzav can you check this error please?

Hi @hdemeillon,
Could you send me the dashboard link to the device and open the device for support access in order to further investigate your issue? This can be done through the dashboard, in the actions panel of the device.

Also @hdemeillon could you share some device details (os & supervisor version)?

In the absence of the details we asked for there’s not much we can do to investigate this issue further.

Here is the device id https://dashboard.resin.io/devices/2bfb8773faac764d60e0f47c35f0c207

I have tried to update resinos however it has been stuck at 50% for over a week and I can’t get access to it as it is thousands of miles away.

Also, can someone from resin.io point me to docs or explain what happens when a resin device is set to be upgraded to later version please?

@hdemeillon checking it out

Hi @hdemeillon the device is fixed up now. Your device was already running the new system, but it was running an old supervisor, which is known not to work on the new version, thus the OS version/application/etc… was not updated in the dashboard (the supervisor does that) :memo:

So here’s what happened:

  • the device’s OS was successfully updated; the supervisor update stage did not succeed for some reason (ie. the new supervisor for the device couldn’t be marked in the API), probably some transient API issue. In the update it is a warning currenctly, not a failure, so the updater progressed and rebooted
  • after reboot, the supervisor did not start as supervisor v6.1.2 does not work on resinOS 2.9.x, hence the stall
  • the fix was manually tagging the device for a supervisor update and running it

Most of the info was gathered from the resinHUP logs (available if you connect to the host OS in the web terminal or resin-cli), at /mnt/data/resinhup.

See more about the updates at https://docs.resin.io/updates/self-service/ and the links within!