[object Object] error loop

$ Starting application 'registry2.resin.io/xxx'
$ Failed to start application 'registry2.resin.io/xxx' due to [object Object]
$ Failed to update application 'registry2.resin.io/xxx' due to [object Object]

My application running raspbian:latest on a Pi ZeroW seems to work fine for a time, then starts throwing [object Object] errors that I can only seem to be able to fix by reimaging my SD card and starting again

When this error occurs, remotely restarting the application fails and if I try to remote reboot, the dashboard itself throws an error banner stating:

Request error: [object Object]

Seems to be the same as #1777

Hello there – what resinOS/Supervisor version is your device on? The “[object Object]” logging issue has been fixed in recent versions – see here: https://github.com/resin-io/resin-supervisor/pull/490 . It might help uncover the underlying issue if the device is updated.


HOST OS VERSION Resin OS 2.2.0+rev1 (prod) 

Yes, the fix above was included in Supervisor 6.2.9 which AFAIK was included with resinOS around version 2.4.0. You might want to update the device via the Dashboard and see if that helps.

Ok, sounds like a plan. So if the application cannot launch, is there a way to update via the Dashboard?

  • Terminal is not available as application has not launched;
  • Resin ssh is therefore also not available;
  • Downloading a new resinOS image still references supervisor v6.1.2, resinOS 2.2

Hmm, yeah it seems resinOS 2.2.0 is the latest version for Pi Zero – we’ll definitely have a newer version soon (TBD) that you’ll be able to update to. If you’re blocked however, in the meantime we can remotely update the Supervisor only – can you reach out to us via the Dashboard’s in-app support chat?

I’m not sure I understand your other questions, can you clarify?

any updates on this? I’m using a rpi zero wireless and also on same resinos and supervisor as @swgn and getting :

29.11.17 10:26:13 (+0800) Failed to start application 'registry2.resin.io/blah/502ef4d31ab7f7a09de370d12d90d1d075a54086' due to '[object Object]'

I wondered if it was my Dockerfile but I have this working on a rpi3 without issues. I have tried resin/%%RESIN_MACHINE_NAME%%-alpine and manually specified pi zero (aka resin/raspberry-pi-alpine) yet it still won’t run.

Hi, the latest resinOS release for rpi zero that includes the fix is about to get tested so it will get released soon.

How can I get notified?

Hi @izavits , any updates on the latest resinOS release for rpi ZeroW?

We have a remote raspberry pi zero W deployed on a client site that is locked, log keeps printing 'Failed to update application ‘registry2.resin.io/……’ due to ‘[object Object]’’

Restarting/rebooting the device doesn’t help. We also tried just about anything with the Supervisor remote API, again no luck.

It’s really hard to go to the client site and replace the SD image, is there anything else we can do?
Please help!


Hey Alex, we’re still testing the release and will let you know as soon as it’s available.

Hi everybody. We have released version 2.7.8+rev1 for the raspberrypi 1, raspberry pi zero and raspberrypi zero wireless.
This release should fix the above mentioned problem. Can you update to that version and let us know if you still see this issue?

Hey, I have the same issue right now on a raspberrypi 2, HOST OS VERSION: Resin OS 2.2.0+rev1 (prod), SUPERVISOR VERSION: 6.1.2:

It is stuck in a loop of:

25.12.17 13:57:58 (+0100) Killing application ‘registry2…’
25.12.17 13:57:58 (+0100) Failed to kill application ‘registry2…’ due to ‘[object Object]’
25.12.17 13:57:58 (+0100) Failed to update application ‘registry2…’ due to ‘[object Object]’
25.12.17 13:58:30 (+0100) Killing application ‘registry2…’
25.12.17 13:58:30 (+0100) Failed to kill application ‘registry2…’ due to ‘[object Object]’
25.12.17 13:58:30 (+0100) Failed to update application ‘registry2…’ due to ‘[object Object]’

I don’t have physical access to the raspberry, so i cannot reset the image right now. Is there anything I can do from the dashboard?

I switched the update strategy lately, because the sd card is small (2gb) and so i switched to delete-then-download, which worked fine for a few times, but since the latest restart it seems to be stuck in that loop. Changing the strategy back did not help.

Thanks for any hints!

In addition to that, I cannot reboot the raspberrypi, because it says: Request error: [object Object]. In the chrome dev console it says: {"Data":"","Error":"(HTTP code 404) no such container - No such container: null "}.

So reboot does not work because there is no container running … restarting the application does also not work… I’m afraid that there is nothing I can do. SSH does also not work, because the application container is always restarting and ssh to the host os does not work with my resin OS version…

Hi, @p0wl
We are planning for a newer resinOS release soon for the RPi2 that will fix this issue.
In case that you are still facing this issue, could you send/PM me the dashboard link to the device and enable support access in order to further investigate your issue? This can be done in the dashboard in the actions panel. We are probably going to need access for at least one day.

Hi @thgreasi, thanks for your response!

I had to call someone to disconnect / reconnect the raspberry pi from power. That solved the issue and it did not appear since then.

Looking forward to the new resinOS release. If the issue appears again in the meantime, I will enable support access and send you a PM.

Thanks for your support and your awesome work!

The problem occured again, just now. I activated support access, but I can’t find a button in this forum to write a PM to you… Am I blind or is the functionality not activated for me?

Can you give me an email address or something?

Hi @p0wl ! since the newer OS version is not released for the pi2 yet, what we can do if you want is update the Supervisor version on your device, which will fix this issue. Then once the newer OS is out you can do a full OS update. How does this sound?

Same goes for @alex, @hdemeillon, @swgn if you point us to affected devices.

Sounds great. I already enabled support access and sent the dashboard link to @thgreasi.