Raspberry Pi 4B stuck on splash screen. Green LED blinks 4 short times

RPI4 Boots normally until the splash screen where after a few seconds, the LED starts blinking 4 short times followed by a pause and the display hangs on the Balena logo.

I’m using the new image from the dashboard (balena-cloud-aura-raspberrypi4-64-2.41.0+rev4-dev-v10.2.2.img.zip) on a previously tested Class 10 SanDisk ExtremePro 32gb card.

This troubleshooting page says this blink pattern indicates a network connection error https://www.balena.io/docs/faq/troubleshooting/troubleshooting/

The network I’m connecting to is a 5G router that I’ve got several other balena RPI3s connected to. I confirmed WiFi credentials in the system-connections/resin-wifi-0 file are correct.

A test with the latest NOOBS has the same board and SD booting and connecting properly.

Any suggestions?

Update: After creating a brand new app with the RPI4 set as the default type, downloading that image, flashing, and booting, it moves past the flash screen and hangs with supervisor link not ready.

Fixed: Seems like it was just an issue of the architecture of the app being wrong. After using the image from the new app (with the default board as the RPI4) it eventually connected. Thanks, y’all!

1 Like

We are having the same issue on a completely new app for Raspberry Pi 4. The internet settings are the same as we have used previously with the RPi 3 that has worked fine however the green LED flashes 4 times when trying to connect the RPi 4.

I cannot confirm what the last displayed message on boot is as the splash screen displays without every showing any boot messages. I have attempted to disable the splash screen in the config.txt however this has not had any effect.

Has anyone else experienced these issues?

It seemed like I had to wait longer than usual for it to boot up - possibly 10 minutes for the first time. I suggest trying to wait it out and report back if it still doesn’t boot after 10 mins.

Thanks for the quick reply @Jassky! I have given it some time to connect but its still not working. I will try downloading the image again and copying over the system connections.

If you haven’t yet - check the wifi credentials in your image. I forget the exact file location but it’s something like /system-connections/resin-wifi-01.

@hpgmiskin, let us know the result of downloading the image again and double checking the system connections folder. Waiting 10 minutes for the first boot also does not seem right… If it was necessary to wait that long, it would be something to investigate and fix.

I have managed to get a Raspberry Pi 4 connected to balena when flashed with an image for a RPi4 application connected to an unsecured wireless network. I will test permutations of a secured network and RPi3 application and report back what is the weak link.

1 Like

Hi @hpgmiskin,

Thanks for reporting back your results, please keep us updated!