InkyShot stuck at green light four flashes

InkyShot has been fine for several days/weeks, but today gave the “…walkies” message.

Pi shows 4 flashes on the green status LED.

Tried reformat and re-write image, tried on two different SD cards.
(balena-cloud-inkyshot-raspberry-pi-2.54.2+rev1-dev-v11.12.4.img)

Always the same - boots to Balena splash screen, then four flashes on green led.

Any advice, please?

Thank you.

Hey @Richard238 thanks for posting.

Just to confirm, you are using a Pi Zero WH?

Did you update or change anything with the setup you had working previously immediately before it stopped working?

Also, this thread on the Raspberry Pi forums has some useful information in it:

These are the other patterns that the ACT LED might show during a failed boot, together with their meanings (the below blink codes are NOT valid for a RPI4, read the RPI4 section for ACT LED flash messages!):

  • 3 flashes: start.elf not found
  • 4 flashes: start.elf not launch-able (corrupt) See below: (not valid for RPI4! On an RPI4 four flashes means no boot code found!)
  • 7 flashes: kernel.img not found
  • 8 flashes: SDRAM not recognized. You need newer bootcode.bin/start.elf firmware, or your SDRAM is damaged

Thanks

Yes, Pi Zero WH
Balena Etcher used to create the OS image on the SD card.
Nothing changed whatsoever.

@Richard238 can you check the SD card isn’t physically damaged at all? And it’s definitely correctly seated in the card slot?

And I don’t suppose you have another Raspberry Pi you could try the SD card with?

It sounds like it could be an issue with a corrupted file on the SD card or another issue with the card itself or the connection with the SD card in the slot, based on the lights flashing.

This is also in the boot problems thread:

Note that 4 flashes could be an indication of a more or less broken SD-card connector. If Databit 1 is connected, but one of the other three Databits doesn’t make contact, so the SD-card only works in 1-bit (SPI) mode, then this will lead to the four flashes error! Check if all pins of your card holder make good contact with the card!

I reformatted the card using SD Formatter.
Imaged it with latest Pi OS
Worked fine.
Installed Pimoroni InkyPhat, all OK.
When I have time, I’ll try again with InkyShot.

@Richard238 the formatting with the SD formatter tool could have been what sorted it.

When you try again with the inkyshot, make sure you select the Raspberry Pi (v1 / Zero / Zero W) option when deploying to download the image from balenaCloud.

Let us know how you get on :+1: