Ralink Wireless USB Adapter

rt2x00usb_vendor_request: Error - Vendor Request 0x07 failed for offset 0x1000 with error -110

This message keeps scrolling through DMESG. We use RT5370 and this is causing performance pains. https://www.amazon.com/gp/product/B00H95C0A2/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&psc=1

Recommendations on other USB to external wifi antenna cards are accepted as well as solutions to this problem.

Hi @jsmedley, we recommend the chipset RT5572.

Last month my teammate made a research about 5GHz USB adapters. Let me paraphrase and share his summary.

According to this article most manufacturers don’t count Linux as one of the supported OSs. There are some exceptions but those apply to 2,4GHz.

Here is explained why is finding a USB Wifi Device for Linux difficult. The summary of it all is that USB Wifi Device producers don’t put the same chipset in one branded product. For example the Panda PAU05 300Mbps can be found with two different chipsets:

  • RT5372
  • RT2870

The RT5572 is a known chipset which has Linux kernel support. The problem is that this chipset is old and there seem to be a few devices with this chipset available on the market. In this wikidev there are all the devices which have the RT5572 chipset. The Panda Wireless PAU09 N600 is the newest one (est. launched in 2016).

Let us know how it goes with your setup.

I tried the Panda Wireless and had issues with it as well. I think its a combo of the SimCOM7100A that we use and the Ralink chipsets.

I’m gonna give this one a try with an Atheros chipset and see how it goes.
https://www.thinkpenguin.com/gnu-linux/penguin-wireless-n-usb-adapter-w-external-antenna-gnu-linux-tpe-n150usbl

I can verify what @gelbal said.

I also had that exact error plus an error about a queue, not flushing.

We launched on the RT5370, had problems staying online and then switched to the RT5572 which we have had far fewer problems with. I think the problems we have now are all Network manger related.

Our final device has 4 RT5370 and 1 RT5572.

By far the best source is alibaba, sellers seem to have an inventory of the chipset and are happy to sell it. At least at our scale.

Good luck,
I just spend the better part of two months working on wifi issues.

I would also be interested in what you learn.
-Thomas

The AR9271 worked perfectly. No dmesg errors, no slow boots and quick connect to WiFi. Never looking back at RaLink.