Wifi Connect: TP-LINK TL-WN722N: The device does not support Access Point mode

Hello! I’m trying to use Wifi-Connect with Balena, a Raspberry Pi CM4, and a TL-WN722N as recommended by the Readme here.

However, I’m getting the following D-Bus error when Wifi Connect tries to start an access point:

Can anyone advise on why that might be?

 wifi-connect  [network_manager::dbus_api:ERROR] org.freedesktop.NetworkManager::AddAndActivateConnection method call failed on /org/freedesktop/NetworkManager
 wifi-connect  Error: Creating the captive portal failed
 wifi-connect    caused by: D-Bus failure: org.freedesktop.NetworkManager::AddAndActivateConnection method call failed on /org/freedesktop/NetworkManager
 wifi-connect    caused by: "the device does not support Access Point mode"
1 Like

For reference I also created a Github issue here: TP-LINK TL-WN722N: The device does not support Access Point mode · Issue #413 · balena-os/wifi-connect · GitHub

Not ideal, but, can you test with a different WiFi dongle by chance Keenan? What I want to determine is, does the source of the problem exist in DBUS / WiFi-Connect, or, is the particular WiFi adapter the cause here. Thanks!

Yup I can do that shortly, though I don’t have another one from the approved list, I’ll try a few others.

I’ll also try on a raspberry Pi 4 normal rather than the CM4, as I know that has a different Balena build and maybe that has something to do with it.

1 Like

I guess the answer is extremely simple and horrifying at the same time: Version 2 vs. Version 1
TL;DR - there are different versions of this card. v1 is with Atheros, v2 with RealTek Chipset. v2 is basically not useable, I guess maybe you got this one? :cry: - maybe something to add to the Wiki page?

Ah man that’s really lame. Yeah that definitely deserves a note on the Github Readme here which doesn’t really make that plain.

Are there really no workarounds to get that chipset to work in AP mode? That chipset theoretically supports AP mode according to the docs, but I guess doesn’t play nice with Network Manager?

I had some problems with plain Raspbian back in the day with a similar issue and there was some workaround, but that was basically hacking together kernel modules. It worked in the end, but was unreliable. Trying to do something in balenaOS would probably not something you could do for production usage, if at all. You would need to build your own versions yourself - to be honest - it is not worth the hassle. I am telling you that as (see above) already burned child, in the end I changed to Atheros in my project and was very happy with that.

1 Like

Ah darn. Is there a specific model you’ve been able to buy that consistently works with Wifi Connect? There was already a small list on the Wifi Connect supported docs and now I’m not sure what to actually buy to use. Thanks!

I have not yet bought anything in the last 4+ years, so no.
But in your case, I would just look for some USB Wifi Sticks with Atheros AR9271 in them and that should do the trick :slight_smile: (I think Ebay and other sources should have them :))

1 Like

Ah thanks man!

1 Like

Just catching up on the thread, thanks @nmaas87 ! I didn’t realize there were two versions of the WN722N, so, yes we will need to update the docs to make note of the v1 versus the v2. I wonder if there was no such thing as a v2 when we tested and documented it! :slight_smile:


Haha yeah I would love to identify a wifi dongle that works well with Wifi connect as an access point that you can reliably buy in the US from a vendor that is not EBay haha. Any suggestions would be great :slight_smile:

@keenanjohnson Sorry for the lag here. We’ll work on updating that list of supported devices. I checked in with a teammate and they stand by the list on our main docs of supported dongles: Supported WiFi adapters - Balena Documentation

Hope this helps!



I am confused by this message. The Wifi-Connect page states the RTL8188CUS does not work and similar chipsets are not expected to work.

The recommended TL-WM725N utilizes both the RTL8188CUS and RTL8188EUS depending on the version. The ones I just purchased from Amazon are running RTL8188EUS. I can see and connect to Wifi networks, but WiFI-Connect fails to initialize an AP and the captive portal.

Starting Wifi Connect
[network_manager::device:WARN] Undefined device type: 29
WiFi device: wlan0
Access points: [###REDACTED###]
Starting access point...
[network_manager::dbus_api:ERROR] org.freedesktop.NetworkManager::AddAndActivateConnection method call failed on /org/freedesktop/NetworkManager
Error: Creating the captive portal failed
  caused by: D-Bus failure: org.freedesktop.NetworkManager::AddAndActivateConnection method call failed on /org/freedesktop/NetworkManager
  caused by: D-Bus failure: Method call failed after 10 retries

However, when researching why I couldn’t get WiFi-Connect to work with my TL-WN725N, I see it is a recommended adapter on the Balena page. I actually picked it after looking through the elinux list.

1 Like

Welcome to the forums @judman13 :)!
Could you please share where you found the TL-WN725N was recommended?

The official page does only recognize the Panda N600 Dual-Band ( Supported WiFi adapters - Balena Documentation ) - and there are additional entries for the TP-LINK TL-WN722N (Atheros AR9271) / ModMyPi (Ralink RT3070) / ThePiHut (Ralink RT5370) on the Github page: GitHub - balena-os/wifi-connect: Easy WiFi setup for Linux devices from your mobile phone or laptop

As you are saying correctly, the RTL8188 variants seems not to work at all, with the TL-WN725N also stated as not working ( TP-LINK TL-WN722N: The device does not support Access Point mode · Issue #413 · balena-os/wifi-connect · GitHub ).

If you have a link you could send us where there is an official statement that they should work I would like to have this removed so that no ones get confused about this. Thank you!

Thanks for the response @nmaas87!

I thought I was losing my mind for a while, but I think the list I used was updated shortly after I posted.

If you look at the commit history for the wifi-dongles.md in the docs it was up dated on Oct 19th. Before that I think it looked like this (wifi-dongles: update list · balena-io/docs@299c525 · GitHub) which clearly lists the TL-WN725N. I am not great with github commit history so I could be understanding the history here.

There also was a link somewhere to the Elinux Wifi Adapater page which, in the footnotes, does list the TL-WN725N as working with AP mode. That was probably a bad reach on my part to bridge the two docs and assume it would function.

As it stands now, the docs are difference than two months ago and things seem clearer than before!

1 Like

Thanks so much for reporting this back.
Yeah looks like someone cleaned up the sections, which is really good, because we don’t want false informations. It also looks like the Amazon for the TP-Link went to a site which listed an older TP-Link stick, which was now somewhat replaced by the TL-WN725N (which will not worked) - and I guess this was one of the reasons that this was cleaned up (“- Remove discontinued dongles” is listed as one of the reasons).
Sorry that you had a bad experience and I hope you can find a working one now for your project.

Yes, I ended up with the Panda units in 3 Pi’s and they work flawlessly. Wifi connect is a great project!

Thanks for the support.

1 Like

You’re most welcome :slight_smile: Happy that it works now!