Problem with certificates while building a TTN gateway with Balena cloud

At the moment building a gateway with RAK7248 to interact with TTN. Using Balena cloud to roleout the software to the Raspberry pi in theR AK7248. Part of the summer academy. On Balena cloudi see a good working gateway, but it doesn’t connect tot the TTN-stack. it gives these loggings

When I do a restart it gives these loggings: (can’t post a second picture because I am a new user.) its says: Error missing configuration define either TTN_STACK_VERSION or TC_URI and TC_TRUST

I followed the instruction to the letter but no joy. Can somebody point me in the right direction?

After the restart I get this warning in the loggings:

Which is strange because I filled the TTN_STACK_VERSION with 3 which should result in that TC_URI and TC_TRUST will be automatically filled. I tried a lot of different things but am fully stuck ant the moment.

Problem solved. I inserted the wrong TC_KEY.

Glad you found a solution for the issue you are facing and reaching back to help the community. Let us know if you need any more help.

I will, now busy discovering all the features. Thanks again.