problem with a thread

I have a service that records rtsp stream, written in python, i’m using ffmpeg and opening a thread that capture the stream.
i’ve used journalctl --no-pager -a and saw that i’m getting an error:
kernel: smsc95xx 2-1.1:1.0 cam1: kevent 2 may have been dropped
i’ve read that i need to change vm.min_free_kbytes to 32768.

Is that a setting i’m able to change using network manager?

Could you please give us more details on what you are trying to accomplish here?
Are you trying to setup a camera? Here are some instructions that may be useful

this is the flow:
we’ve set up two additional network interfaces.
i’m just running an ffmpeg command that records a camera on this interface (without any transcoding), and after 5 minutes, both threads was closed, and the error i see is what i’ve written (the error from journalctl --no-pager -a)

Thanks for the extra context.
You can change the vm.min_free_kbytes sysctl parameter, which appear tunable as part of compose 2.1: sysctls in docker-compose.yml.
Please let us know if this helps.

this is my current compose file, but the service is not starting.
am i missing something?

version: ‘2.1’




container_name: recordingservice


  context: ./recordingservice


  - "49525"


  - 'resin-data:/data'

privileged: true


  vm.min_free_kbytes: 32768

Hi there,

A few questions to see if I can pin the issue down:

  1. How are you building/deploying the app? Are you using balena push?
  2. You say the service is not starting, is there any error message?

You could also enable support access and let me know the device UUID (in a private message), and I’ll take a look.