Fail in saving rtsp stream above 5mbps

Hello,
i’ve been running for the last few weeks an application that is using ffmpeg on the raspberry pi 3 inside a container.
up till now it worked fine, but now, every time the stream bit rate is above 5Mbps, ffmpeg just stops at the beginning of the record (from another computer in the lan i can record easily the exact same stream with ffmpeg).
i’m wondering if i should configure anything else on the balena OS?
i’ve already tried switching SD, and used a new SD, created a new device in the application, and ran into the exact same problem.
this worked around a week ago, and i didnt change anything in the container parameters.
am i missing something?

Hi,

Did anything change, such as an OS or application update, or the physical conditions of the rpi?

If you enable support access and share the device’s UUID we can take a look.

I’ve missed your reply.
yes, would be great if you can take a look.
send you in private message?

Hi
Please do

Hello, did you manage to understand/solve this issue? We experience a similar issue using an RTSP source in a container running GStreamer on Jetson Nano devices with BalenaOS.

Hi @mellerdaniel

The previous status on this support thread was that you would have sent the UUID of the initial device to one of the previous support agents in a private message, but it seems that they have not received this yet? Can I ask you to please send me the UUID in a private message, and to enable support access on the device? Then we will assist you as soon as we can!

Thank you, and kind regards
Alida

Hi, i did send… no response yet, waiting :slight_smile:

Hi @mellerdaniel

Thanks, we have received the UUID. I can’t access the device though, can you please check that support access is enabled for this device, and confirm in this thread? (If you enabled it last week, it might need to be enabled again.) Thanks!

Kind regards
Alida

Ill connect it tomorrow and will send you, thanks!

Hi,

My first thought when I saw this was that it’s likely a throughput issue on the SD card; if there have been sustained writes over a period of time then the wear-leveling in the card’s controller could be slowing it down. I see that you’ve replaced the card, and provisioned a new device and still have the issue so I appreciate that this might not be the cause though. It is also a confusing that it used to work, and now it doesn’t, so I am wondering if the source of the RTSP stream is in some way sending data which is causing the issue when decoding.

Do you have the same problem when writing the stream to /dev/null? This might help understand if it’s a decoding issue vs a IO throughput issue.