Problem to flash sd or usb Kali Linux

I have a big problem with balenaEtcher. I have tried very many times to flashing Kali Linux on a USB and SD key, but every time it gives me an error in which it makes the devices no longer readable and windows 10 continually asks me to format them already from the Etcher verification phase. Two partitions are created after flashing, one with the size of Kali, which is the partition that then becomes damaged and requires formatting, and one with 1mb of space. I’ve been wasting time on it for two days. only once did the flashing succeed tonight, but this morning I plugged the usb stick to the pc and it was unable to detect the boot of Kali.

Hello @sudosu welcome to the balena community!

Sorry to hear that you are having this issue.

Did you try to use this tool to fix your USB or SD card on Windows 10? How to use DiskPart to clean and format drive not working on Windows 10 | Windows Central

Nop but I solved the problem by mounting the usb key with linux. maybe I also understood why it was not working on the laptop, it had blocked starting from the bios. comuqnue thanks for the reply!

Aha, yep, that will do it. Glad you solved it. :slight_smile: