Pls help! Installing etcher on a rapsberry pi 3B+

Just hoping if anyone can help me overcome an Etcher installation hitch.

I’ve tried following the instructions
downloading the x64 file and unzipping it in Terminal, which appears to have worked. After a wee error, I moved it to a dir /opt and tried to run it [see below], but it just says

“cannot execute binary file: Exec format error”

Does anyone have any idea what I am doing wrong please? I am very new to all this.

Grateful thanks


pi@raspberrypi:~/Downloads unzip Archive: inflating: balenaEtcher-1.5.50-x64.AppImage pi@raspberrypi:~/Downloads /opt/balenaEtcher-1.5.50-x64.AppImage
bash: /opt/balenaEtcher-1.5.50-x64.AppImage: No such file or directory
pi@raspberrypi:~/Downloads sudo mv balenaEtcher-1.5.50-x64.AppImage /opt pi@raspberrypi:~/Downloads /opt/balenaEtcher-1.5.50-x64.AppImage
bash: /opt/balenaEtcher-1.5.50-x64.AppImage: cannot execute binary file: Exec format error

Hi there,

I notice in your pasted logs it shows you’re on a Raspberry Pi and trying to use Etcher? The x64 binaries are for x64 (also known as AMD64) architecture, whereas the Raspberry Pi runs an Arm architecture. This would explain the Exec format error that you’re seeing.

We currently only support AMD64 Linux, macOS and Windows as Etcher targets, I’m afraid, although you should be able to build from source for another architecture if you wanted to run Etcher on it (with the dependents it requires).

Hope this help!

Best regards, Heds