PiHole - Public URL Doesn't appear to work.


Apologies if this has been covered previously, i cannot find any topics covering this specific issue.

My issue may come from ignorance as i am new to containers in general.

I have configured PiHole successfully in the past on a number of different networks and have had no issues.

I have enabled the ‘Public IP’ of the PiHole but when i attempt to navigate to it, i recieve the following in the browser:

I also have an issue with the DNS & DHCP server disabling on reboot of the Pi though this is probably a different issue…

Anyone able to point me in the right direction?


Device Public URL is a balena feature that enables web forwarding and generates a web accessible url for any applicable devices, you can enable/disable it from the dashboard. More details can be found in our docs here https://www.balena.io/docs/learn/manage/actions/#enable-public-device-url


Thank you for the link but unfortunatley i had come accross this already but the information there does not help.

I have enabled the Public URL from the dashboard, the above is the error i recieve even though the URL is enabled on the device.

Hello and thanks for reporting this, it turns out there was an issue with our vpn which was causing the public URL to fail under some circumstances. We have a fix ready for this and are testing it in our staging environment, if all goes well it should be available in production in the next couple of days. Sorry for the inconvenience.


Thank you for the info.

I will try again once your fix is in place.

Actually, looks like my estimates were too pessimistic, the new VPN should have been deployed to production just moments ago. Give it another try and let us know if everything is working as expected


I am still experiencing issues with the Public URL.

I recieve the following in browser.

I have set Javascript and Flash to allow in browser but stil recieve the above.

Hi, I see a “Javascript disabled” message in the screenshot you provided. Are you sure it is enabled? Maybe you can install a different browser just to verify whether you will receive the same error. E.g. if you are using Chrome, you may try with Firefox, etc.


As stated before, I had set Javascript and Flash to allow in browser but stil recieve the above.

I had also tested in other browsers including Firefox.

In firefox if i change “plugins.flashBlock.enabled” to false the following is displayed:

To confirm i have enabled the URL from the device summary page:

How about trying with a different browser like Chrome? The errors you see indicate that your Firefox is somehow misconfigured.


The original browser i was trying was Google Chrome.

The Firefox screenshot above is from a freshly installed Firefox on my develepment computer. The only setting changed being “plugins.flashBlock.enabled” which i have changed to fasle to allow the message to be displayed. When this Flash setting is left to default (True) a message is displayed stating Java is disabled. Please see the below screenshot:


The same message is also produced in Internet Explorer, please see below.

I actually just opened your URL in my browser and I see the error there. Both in Firefox and Chrome. We should get back to you soon with more information.

Thank you.

Hi, the page displayed on the root path of PiHole dashboard does not really work.
The actual dashboard is under /admin.

If you add /admin to your URL, it should work. Also, make sure you use HTTPs in your URL.


That appears to work once “/admin/” is appended to the URL.

I feel stupid for not trying that…

Thank you for the help.

No worries, it’s very easy to get confused. It would be ideal to have a link from the root page to the admin dashboard, I think.
We opened an issue on the upstream project: