Pi-hole blocks zero queries

I believe I have successfully ported Pi-hole to a Raspberry Pi using balenaCloud. The setup passes the test with “ad blocking enabled”. For starters, I reassigned the DNS server only on my Mac Mini. After more than 24 hours, the dashboard shows 35 queries, with zero blocked. Is this normal?

At this point the console shows 178 queries, zero blocked. I tried logging in to the console, but it does not accept the password I entered at setup time. So I don’t see what actions I have other than starting over, with risk of ending up in the same place.

Hey @BKFC,

Can you access https://blockads.fivefilters.org/?pihole on a new incognito window and see if says Ad blocking enabled!?

Could you grant support access to the device and share the device UUID so that I can take a look?


I think this is the test I did before (running off a Mac and not the entire household yet), and it does say “Ad blocking enabled” (I note that any time my Mac power cycles, the DNS entry reverts back to, and then the test fails).

On your second question: I’m now learning what a UIUD is. To get it, I imagine I would have to be logged into the Raspberry Pi. I tried ssh into it, but that was refused, and for some reason the password I created for the web console doesn’t work either. I also don’t know how to grant support access to this from behind a router.

Addendum: something has changed. Console now reads over 1000 queries, 104 blocked!

Hey @BKFC,

The UUID stands for ‘Universally unique identifier’, which is the id of the device, you can copy by clicking the icon besides the string on the device list or device information.

To grant support access, you need to go to the device page and click on the dropdown besides the lamp:

But by what you just said, 1000 queries and about 10% blocked looks like it is working.
Can you login to the admin section of Pi-Hole?

Thanks for the input. I didn’t realize that the UIUD is displayed on the dashboard. Finding cross-platform Unix commands that provide this turns out to be nontrivial.

It does now appear to work (not sure what I did), and I’ve set the router DNS setting to point to the Raspberry Pi.

I can’t log in to the admin section as it does not accept the password that I provided (maybe too late, but not sure how I can fix it other than by deleting everything and starting over). On the other hand this may be moot.

Block rate is just under 14% now.

Thanks for checking in.


Hey Brad,

I believe you can change the password by changing the value of the environment variable.
Change the value of WEBPASSWORD to another password, and try again.

Thank you

I can change WEBPASSWORD under Device Service Variables in the balena dashboard, but when I try to log in to admin at the device IP/admin address I still get “wrong password"

I will send you a private message, can you answer with the UUID of the device and can you Grant Support Access, so that I can take a look on the device?