Pi 3+ / BalenaSound / Sony sound-bar low volume

First off this is a great project, super glad I you have this advertised during etcher installs! With that said, I set this up on a Pi3+ and plugged it in to a Sony sound-bar setup via audio/RCA cables. Everything works fantastic streaming Spotify with the exception of low volume. I have the sound-bar cranked to max volume and the volume on my iPhone XS streaming the Spotify.

Is it possible to use the HDMI to connect to the sound-bar? I know digital connection is better, just not sure of what my options are.

Background on the sound-bar… When hooked to TV set-up with HDMI it is much louder.

Any advice / suggestions would be greatly appreciated.


Hey, have you tried to change the value of the SYSTEM_OUTPUT_VOLUME variable, detailed here? https://github.com/balenalabs/balena-sound/issues/107 Typically this solves most instances of this problem.

1 Like

Thanks for the help, tried 100 and it did get louder. With that said, is it advisable to go to 150 or 200? At 100 its only marginally louder. Thanks again for your input.

I’m actually not sure, I can check with the team :slight_smile:

1 Like

After speaking with the team, it turns out the volume control command is: amixer -M sset PCM,0 $SYSTEM_OUTPUT_VOLUME% and it appears alsa will not respect a > 100 value there. To answer your original question, it should be completely possible to run the soundbar via HDMI.

1 Like

If I switch to HDMI, do I need to change any settings on the Pi/BalenaSound? Again, thank you for helping!

Hi, it should work without changing settings. I noticed you are running a Pi 3, but if in the future you run on a Pi 4 make sure to check this out: https://sound.balenalabs.io/docs/troubleshooting#no-audio-on-hdmi-output-on-raspberry-pi-4

Thanks! Will try and reply with results.

Switched to HDMI and removed audio/RCA connection. No sound. Sound-bar is set to correct HDMI source. BD (BlueRay) in this case. Maybe I can try different sources, but not sure if that matters.

Hi Ryun, I haven’t tried hot-swapping the audio output on mine, but it might be worth a simple reboot to see if that does anything. You can issue a reboot directly from the Device Details page in balenaCloud. That’s probably the easiest first step in troubleshooting this.