Nvidia Jetson Nano Display issue

I have a problem with getting the display working.
I followed this tutorial:

everything looks very normal and okay. At the end of the tutorial when I try to run the example it complains about the display output.
When I try xrandr it says it cannot open the display. When I manually export DISPLAY to 0.0 or 1.0 still the same thing.
When the system is booting up the display works, up to the splash screen. It looks like the last frame is the Balena splash screen. If I remove the HDMI and put it back it does not show anything anymore.
Thank you for your help.
root@66bf325:/usr/local/cuda-10.0/samples/bin/aarch64/linux/release# export DISPLAY=:0

root@66bf325:/usr/local/cuda-10.0/samples/bin/aarch64/linux/release# xrandr
Can’t open display :0

P.S. My issue is similar to this, the symptoms: however the cube is pretty centred, so I guess the resolution and aspect ratio at bootup are okay.

Hi Nima,

I tried to replicate the issue but couldn’t. I am assuming that xrandr is not able to find the display. Can you post the output of xrandr -d :0 here, so we can see what xrandr is able to identify.

root@66bf325:/usr/local/cuda-10.0/samples/bin/aarch64/linux/release# xrandr -d :0
Can’t open display :0

The carrier board is B01, the new release.
Linux 66bf325 4.9.140-l4t-r32.4.2 #1 SMP PREEMPT Sat Sep 5 11:17:12 UTC 2020 aarch64 aarch64 aarch64 GNU/Linux

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04.5 LTS
Release: 18.04
Codename: bionic

#Copyright © 2011-2013 NVIDIA CORPORATION. All Rights Reserved.

#This is the minimal configuration necessary to use the Tegra driver.
#Please refer to the xorg.conf man page for more configuration
#options provided by the X server, including display-related options
#provided by RandR 1.2 and higher.

#Disable extensions not useful on Tegra.
Section “Module”
Disable “dri”
SubSection “extmod”
Option “omit xfree86-dga”

Section “Device”
Identifier “Tegra0”
Driver “nvidia”
#Allow X server to be started even if no display devices are connected.
Option “AllowEmptyInitialConfiguration” “true”

Hi Nima, Unfortunately that xrandr output doesn’t seem to tell us much. Which version of balenaOS are you using and which version of l4t did you download (looks like 32.4.2 but checking to be sure) There’s also a (soon to be introduced) version of that example repo which does not require manually downloading the l4t files: https://github.com/balena-io-playground/jetson-nano-sample-new I’m wondering if you still have the same issue if you are able to try that?

Sorry for the late reply, the problem still exists. I think it should be a driver or firmware blob issue.
Here is the output of dmesg:

[  707.661399] tegradc tegradc.0: nominal-pclk:148500000 parent:148500000 div:1.0 pclk:148500000 147015000~161865000
[  707.661848] tegradc tegradc.0: hdmi: tmds rate:148500K prod-setting:prod_c_hdmi_75m_150m
[  707.671786] tegradc tegradc.0: hdmi: get RGB quant from EDID.
[  707.671830] tegradc tegradc.0: hdmi: get YCC quant from EDID.
[  707.709047] extcon-disp-state extcon:disp-state: cable 47 state 1
[  707.709062] Extcon AUX1(HDMI) enable
[  707.758642] extcon-disp-state extcon:disp-state: cable 51 state 1
[  707.774366] Extcon HDMI: HPD enabled
[  707.778337] tegradc tegradc.0: hdmi: plugged
cat /sys/kernel/debug/tegra_hdmi/hdmi_status
hotplug state: 1
SCDC present: 0
Forum VSDB present: 0
YCbCr4:2:0 VDB present: 0

This is with the CUDA Dockerfile you mentioned.

Here is the link with my old Dockerfile, which also didn’t work:


I’m able to unblank and blank the display with the following command:

echo 0 > /sys/class/graphics/fb0/blank

So I think the cable, connection, and display are okay. I’m also using external power supply on my jetson, so I’m pretty confident the board is not underpowered.

I just tried the same display on Jetson Xavier with the following JetPack and no Balena and it worked:

Linux nima-xavier 4.9.140-tegra #1 SMP PREEMPT Wed Apr 8 18:15:20 PDT 2020 aarch64 aarch64 aarch64 GNU/Linux

No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 18.04.4 LTS
Release:        18.04
Codename:       bionic

Here is an output from the above Jetson Xavier with working display:

[ 1883.496418] Parent Clock set for DC plld3
[ 1883.502772] tegradc 15200000.nvdisplay: hdmi: tmds rate:148500K prod-setting:prod_c_hdmi_111m_223m
[ 1883.504291] tegradc 15200000.nvdisplay: hdmi: get RGB quant from EDID.
[ 1883.504300] tegradc 15200000.nvdisplay: hdmi: get YCC quant from EDID.
[ 1883.539967] extcon-disp-state external-connection:disp-state: cable 48 state 1
[ 1883.539970] Extcon AUX2(HDMI) enable
[ 1883.540079] extcon-disp-state external-connection:disp-state: cable 51 state 1
[ 1883.540084] Extcon HDMI: HPD enabled


Just to confirm, the application is built on the balenaOS Jetson Xavier image, correct? (As opposed to the Nano, etc.)


I have two boards:

  1. Jetson Nano with B01 Dev board
  2. Jetson Xavier with its dev board.

My Nano is running BalenaOS and My Xavier is running JetPack without any Balena.
I have the following display:

The display works on Xavier with no problem. When I connect the same display to Nano, it only works up to the splash screen and then never receives any more frame.

I never tried the display with Xavier running BalenaOS or Nano running native JetPack.
Sorry for the confusion.

Thank you for your help :slight_smile:

Hi @nima,

Just to double check, do you start X before trying to run the cuda examples or xrandr?

From the logs you pasted it’s possible that the first step in my colleague’s @alanb example doc might have been skipped. Here’s how the sample works on my B01:

root@1939059:/usr/local/cuda-10.0/samples/bin/aarch64/linux/release# xrandr -d :0
Can’t open display :0
root@1939059:/usr/local/cuda-10.0/samples/bin/aarch64/linux/release# X &

root@1939059:/usr/local/cuda-10.0/samples/bin/aarch64/linux/release# xrandr -d :0
Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 16384 x 16384
HDMI-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 510mm x 290mm
1920x1080 60.00*+ 59.95 50.00
1680x1050 59.96
1600x900 60.00
1440x900 59.89
1280x1024 60.00
1280x800 59.81
1280x720 60.00 59.94 50.00
1024x768 60.01
800x600 60.32
720x576 50.00
720x480 59.94
720x400 70.04
640x480 59.94 59.94
DP-0 disconnected (normal left inverted right x axis y axis)
root@1939059:/usr/local/cuda-10.0/samples/2_Graphics/bindlessTexture# ./bindlessTexture
CUDA bindlessTexture Starting…

GPU Device 0: “NVIDIA Tegra X1” with compute capability 5.3

Device 0: < NVIDIA Tegra X1 >, Compute SM 5.3 detected


Thank you for your answer.
I completely forgot to ask about and check the X. My bad. I should have checked it first :slight_smile:

No worries, glad to hear it is all working correctly for you now.