Nvidia Jetson Nano OS

I followed the “Get started with Nvidia Jetson Nano” tutorial, however, I can not get the device up after I flash balena OS.
After I enter the SD Card and power up the device, I see a boot screen and it just stays on that screen.

When adding a new device, I selected the following.
Device Type: Nvidia Jetson Nano SD-CARD (NEW)
Version: 2.56.0+Rev1
Edition: Development
Network Connection: Wifi+Ethernet

Note that I was able to get it working on Raspberry Pi.

Thanks in advance for your help.

Hello,

What do you see on the screen ?

Does the device appear on the dashboard ?

Do you have a serial cable so we can see what happens on the device ?

I’ve attached a photo of the screen i’m referring.

The device does not appear on the dashboard.

I do not have a serial cable but i’ll be happy to go Micro Center or Best Buy and get one. What type of serial cable should I get?

I just found a USBC to USB cable laying around, let me know next steps.

This looks similar to https://forums.developer.nvidia.com/t/new-jetson-nano-not-booting-instead-showing-recovery-screen/74153/12 .
Could you try flashing another SD card ?

Hi again,
I tried two SD Cards. Sandisk Extreme Plus 64 GB and SanDisk High Performance 32 GB.
When I flash the Jetson Nano Developer Kit SD Card Image to both SD cards, the OS starts up.

The problem seems to be only when I flash BalenaOS.

Any other suggestions would be greatly appreciated.

Hello,
Which version of the Jetson Nano board are you using, A02 or B01? (B01 can be identified easily by looking for a second camera connector that the A02 lacks)

Seems I have A02.

Hmmm, I have a Jetson Nano A01, and just downloaded and booted 2.56.0+rev1 successfully, so it does definitely work ok. So, two items here.

First, simply for testing purposes, can you try an “Unmanaged” version of the OS, which you can download from here: https://www.balena.io/os/ (scroll down a ways until you reach the full list of boards). I’m just curious to see if one of those images works for you.

Second, looking at that link Alexis shared, I see some mentions of possible corrupt SPI flash / EEPROM on the board. They mention that using the native Nvidia SDK Manager tooling to flash the board can overwrite that with a fresh copy, so, that might be worth a shot. You’ll need an Ubuntu machine to do it, but they have some good documentation here: https://docs.nvidia.com/sdk-manager/install-with-sdkm-jetson/index.html

Hi,

I tried to reproduce this issue too on a A02 Nano devkit but without success. Like my colleague David mentioned, it’s possible that the SPI contents cause this.

The fastest way to re-write the SPI is to download and unpack the Jetson Nano L4T Driver Package (BSP) archive from Nvidia’s website, put the Jetson Nano in force recovery mode and connect the usb cable to your Linux PC. Make sure you save your data from the SD-CARD placed in the Nano as it will be re-written.

On your PC, In a terminal window go to the path where you extracted the BSP archive and issue:

cd Linux_for_Tegra
sudo ./flash.sh jetson-nano-qspi-sd mmcblk0p1

After flashing is finished, you can remove the jumper used for the recovery, replace the card with the BalenaOS 2.56 one and then check if the board boots.

Thanks guys, let me give that a try. I only have a MacBook Pro so hopefully this can be accomplished with Linux via Virtual Machine.

Hey guys, a quick update.

I ran into problems putting the Jetson Nano in force recovery mode. I’m not sure if this Nano is A02. I compared the diagrams I found on Nvidia of what an A02 looks like compared to Nano I have and there are some differences.

Looks like I have the Jetson Nano 2GB which was just released last month so I’m not sure if that matters.

Here is a link to the board I purchased.

I had problems placing the Nano in force recovery mode mainly because the location of where to place the Jumper did not exist on my board.

In the end, I was able to get it in force recovery mode by issuing the command below from the Jetson Nano terminal
reboot --force forced-recovery

I installed Ubuntu 18.08 on VirtualBox and attempted to run the Jetson Nano L4T Driver Package flash script but it failed to connect to the board.
I then installed the SDK Manager and tried to update that way but it stopped at 99% after many attempts.

I read on the Nvidia forum that VMWare Fusion works best with the process instead of VirtualBox so I installed the VMWare Fusion/Ubuntu/SDK Manager. The update process was successful.

Note that the Nvidia moderator stated that…

When you use SDK Manager, it implicitly flashes QSPI-NOR as well as flashing the SD Card you have inserted into module

Thus I did not continue to use the flash script.

After the SDK Manager was complete I then flash the balenia OS and ended up with the same boot screen. :rage:

Hi @ameikle,

Thanks for clarifying, currently we only have the A02 and B01 models, which work fine with our dashboard images.

The Nano 2GB model was just launched and our test units did not arrive yet, we’ll try to reproduce this issue once we get them and will let you know when we have updates.

Sounds good, thank you!

Hi, we have opened an issue in github that will be updated with progress, see https://github.com/balena-os/balena-jetson/issues/122. We will also updated this thread once the issue is resolved.

1 Like