NUC cannot download my app

Her is the log:

03.11.17 07:40:03 (-0700) Downloading application ''
03.11.17 07:40:57 (-0700) Failed to download application '' due to 'could not get decompression stream: Get dial tcp i/o timeout'

Hey hey, that looks like the network connection was unstable during the download, causing it to fail. Is it still failing to download updates?

Yes, it is looping in Downloading -> Failed -> Downloading state for ~15 hours now. I tried restarting the device. The second it initializes it is going to the same Downloading -> failed -> Downloading state.

Any idea on how to troubleshoot?


P.S. My network connection is stable and on raspbery pi 3 I had no problems downloading the app from the same network.

Hey, could you send me a link to the resin dashboard for the device and enable support access under actions please and I’ll be able to look into this closer

1 Like

Here you go:

The access has been granted for 1 day.

Thanks for help!

Looking at the device it seems to be consistently failing with weird network errors, running the same pull myself works however. The two things I can suggest trying are:

  1. try connecting the device to ethernet to see if that allows the download to succeed
  2. try enabling deltas by setting the RESIN_SUPERVISOR_DELTA config var to 1 (see

So when I tried ethernet cable the app got downloaded!

BUT it does not change the fact that something is wrong, my device is HIGHLY dependent to work over WIFI and apparently something funky happens with the WIFI module. Could you help investigating the issue?

The device is Intel NUC NUC71i3BNH

I extended access to the device for another week.
Please let me know if I can help.


At the moment it looks as though support access isn’t granted to that device, would you mind double checking that and getting back in touch.

@MiluchOK It still looks as support access isn’t granted to that device, could you check the device again for support access?