Failed to download

Hi there,
After pushing my latest code, I now get this error on resin:
Failed to download application ‘’ due to ‘Failed to get image download size of 303b5307a77886b50c9e27ef0301fdb48b5d0xxxx from Status code: 400’

Any idea how this can be solved?

Hi there,

This usually signifies problems with the connection, resulting in an early termination of the image and is usually caused by network connectivity issues. Did you retry again? Does this issue persist?

Best, Ilias

Hi Ilias, that error has indeed disappeared. But now I can’t seem to push any new data. I always get
"Error: Builder disconnected

remote: error: hook declined to update refs/heads/master"

I tried creating a new application and then I could push once, but now again I can’t update anything anymore.

Any input would be much appreciated.

Hello again,

When you update your application, do you also require new dependencies to be installed? This usually has to do when trying to install new dependencies, but the installation is aborted. For instance, if you install dependencies via apt-get install, you can add ‘-y’ in order to assume “yes” when confirmation needed. Is this your case?

Best, Ilias

Hi Ilias,

This is my Dockerfile:


FROM resin/raspberrypi-buildpack-deps:jessie

Set Node Environment Variables


Download Node

RUN curl -SLO “$NODE_VERSION/node-v$NODE_VERSION-linux-armv6hf.tar.gz
&& tar -xzf “node-v$NODE_VERSION-linux-armv6hf.tar.gz” -C /usr/local --strip-components=1
&& rm “node-v$NODE_VERSION-linux-armv6hf.tar.gz”
&& npm install -g npm@"$NPM_VERSION" --unsafe-perm
&& npm cache clear
&& npm config set unsafe-perm true -g --unsafe-perm
&& rm -rf /tmp/*

Initital setup and install

RUN apt-get -y update && apt-get -y install arduino cron procmail unzip g++ gcc usbutils make node-gyp
COPY . /src

NPM Install

RUN cd /src; npm install;

But it already hangs when trying to load the cache:
Robins-MacBook-Air:analog_rpi robinreumers$ git push resin master
Counting objects: 9, done.
Delta compression using up to 4 threads.
Compressing objects: 100% (9/9), done.
Writing objects: 100% (9/9), 2.28 KiB | 0 bytes/s, done.
Total 9 (delta 4), reused 0 (delta 0)

Starting build for fb_robin_reumers/analogconsole, user fb_robin_reumers
Building on 'local’
Pulling old image for caching purposes
Still working…
Error: Builder disconnected

Also, at this point, I cannot ping Is that normal?

Hi again,

the fact that you cannot ping is normal. This is not the problem.
Let me forward your issue to the team please and get back to you.
Thank you for your patience.

Kind Regards, Ilias

Hi Ilias, thanks. I tried a new git init, also tried a new application. Haven’t been able to make it work. Always disconnects after “Pulling old image for caching purposes”.

Hi Ilias, this didn’t work for the past 3 days, but started working again today.

Hi there,
I was about to inform you that we have deployed a new version of our builder.
Glad to hear it works for you now.

Best, Ilias